Xshell Forum

bug / feature?

Last post: Thursday, February 12, 2009 4:57 PM by Support, 4 reply

 
Tuesday, February 3, 2009 5:06 PM - Shai

bug / feature?

 
hello, first of all - thank you for your great job.

I'm using the latest Xshell 3.0,

I wanted to report a bug/issue .. it occurs after a long duration of Xshell being active..
the Mouse device - Instead of actually commit actions .. will print "Chars" into the session.

(clicking on the session - will show few chars on it)


the second feature/advice .. the Compose Bar .... should have a shortcut, to be accessible from keyboard?

another thing .. I've noticed when you reach the left-border of the window, with the 'Pointer' .. it won't let you start a selection .. because its not part of the session .. (3px wide?) .. quite depressing :)


Thanks a lot, Shai.


Program Ver. : Xshell 3.0
Tuesday, February 3, 2009 5:52 PM - Support

Re: bug / feature?

 
Thank you for your suggestion, we will definately consider adding this short cut key in the future edition.

Also, about the problem, could you tell us how we can duplicate it? This problem might be related to your server, router or even firewall settings. Please share with us as much information as you can and we will try to duplicate the problem.



---
Technical Support


Did you know that Xshell and Xftp are free for home and school use? To find out more, please click here.
Wednesday, February 4, 2009 2:10 AM - Shai

Re: Re: bug / feature?

 
unfortunately it happens to me at least once a week.
my environment: 2.4 c2d, 3gb ddr2, XP SP3

my common 'uptimes' are about 30-40 days.
after few days of keeping the Xshell sessions open... it happens ..

btw, I increase the buffer to 15,000 lines,
ad I use on average, 5-10 sessions opened (tabs)

hope I could assist, Next time it happens I'll provide the actual "Chars" it creates

Shai.
Wednesday, February 4, 2009 10:27 AM - Shai

Re: Re: Re: bug / feature?

 
here, just happened to me again.

when I click the left button:
"[M EF"

when I release the left button:
"[M#EF"

right click:
"[M"b;"


I tried: "clear"
but it didn't sort it out..

tried "reset" .. it changed the Window's mode (from Maximized -> not-Maximized mode)

and didn't work.

opened a new session ..
it works in the new session.

anything further I can shed?
Thursday, February 12, 2009 4:57 PM - Support

Re: Re: Re: Re: bug / feature?

 
We have found out that those characters are sent out when the terminal is used in application mode to utilize mouse clicks. However, sometimes the terminal application exits without notifying it to terminal and when it does that Xshell has no way of knowing if terminal is out of application mode and still tries to send mouse clicks.

The problem could not be duplicate. However, if you can tell us the name/version of the application and a brief procedure to duplicate the problem, we will try to duplicate it again.

Thank you for your cooperation.


---
Technical Support


Did you know that Xshell and Xftp are free for home and school use? To find out more, please click here.