Xshell Forum

about the font setup when use Xshell to telnet Redhat8

Last post: Wednesday, December 24, 2003 6:00 PM by Support, 3 reply

 
Wednesday, December 24, 2003 11:45 AM - zhang

about the font setup when use Xshell to telnet Redhat8

 
hi,

I have a trial version of Xshell, when I telnet to
Redhat8, there are some font can't display correctly when use some command, for example : "info lsof", I have changed every font, but can't solve this problem, could you give me some advice for it, thanks.
Wednesday, December 24, 2003 11:53 AM - Support

Re: about the font setup when use Xshell to telnet Redhat8

 
We need additional information to figure out the reason. Please provide us with the following:

- The language of RedHat 8. You can find it by running "echo $LANG" at the command-line prompt.
- The language of your Windows machine.
- A screen-shot of the problem.

Thanks for your cooperation.

----
Technical Support
Wednesday, December 24, 2003 12:15 PM - zhang

Re: Re: about the font setup when use Xshell to telnet Redhat8

 
-echo $LANG
result is : en_US.UTF-8

-my windows version is english professional

-the screen-shot please see the attachment

thanks

Wednesday, December 24, 2003 6:00 PM - Support

Re: Re: Re: about the font setup when use Xshell to telnet Redhat8

 

We know that the man and info utility can't process special characters such as "-" correctly with en_US.UTF8 locale.

You can do one of the following:

  1. Try to set the locale to "en_US" as following:

     # export LANG=en_US

  2. Try to use "man" instead "info". To "man" correctly,
     you should change the PAGER option in "/etc/man.conf":

     #PAGER   /usr/bin/less -isr
     PAGER   /bin/more

It seems that the "less" and related programs cannot process unicode documents well in RedHat 8. We have no such report for RedHat 9.

I hope this can help you.