Xshell Forum

Xshell 2.0 beta process disappear suddenly

Last post: Wednesday, June 22, 2005 1:46 PM by Support, 3 reply

 
Tuesday, June 21, 2005 1:33 PM - Otem

Xshell 2.0 beta process disappear suddenly

 
I am trying Xshell 2.0 beta build 107. Xshell session always disappear suddenly while working a while. The remote server shows that the connection is still established. However, I cannot find it in the taskbar as well as Windows task manager. This happens even I set "send keep alive messages while the session is connected" to 30 seconds.

I was working with Windows XP professional SP2 on an Intel Celeon laptop and was connected to RedHat Linux AS 4.0 on a Dell Xeon workstation.

I did not encounter this defective with earlier versions of Xshell.

Thanks.
Otem
Tuesday, June 21, 2005 3:31 PM - Support

Re: Xshell 2.0 beta process disappear suddenly

 
We are currently building a testing environment. Meanwhile, please tell us the following information.

1. Connection method (Telnet, SSH, Rlogin, etc)
2. Does the same problem occur in other users¿ accounts as well?
3. Procedure to reproduce your problem.
4. If you can, try connecting from a different computer.

Thank you for your cooperation.
Wednesday, June 22, 2005 1:27 AM - Otem

Re: Re: Xshell 2.0 beta process disappear suddenly

 
1. Connection method (Telnet, SSH, Rlogin, etc)

SSH 2
2. Does the same problem occur in other users¿ accounts as well?

Yes.
3. Procedure to reproduce your problem.

It just happens. After I worked a little while (undetermined length), I just cannot find one Xshell process. Other Xshell processes may still there. I usually open several sessions at a time. They just missed one after another randomly. If there is a front process running at remote server, such as vim, it will keep the window from disappearing. Background processes or processes which do not write to standard output, however, do not help. Does it have something to do with firewalls?

Thanks.
Wednesday, June 22, 2005 1:46 PM - Support

Re: Re: Re: Xshell 2.0 beta process disappear suddenly

 
Your firewall might be disconnecting the sessions that are idle. Please contact your network administrator and let him know about this problem.

Also, please check with your system administrator to see if anything has been changed on the remote server since the last successful use.

Hope this will solve your problem.