Xshell Forum

copying to clipboard with mouse

Last post: Thursday, March 10, 2016 8:58 PM by Support, 5 reply

 
Sunday, May 25, 2008 6:17 AM - Todvard

copying to clipboard with mouse

 
Hi NetSarang Team,

when i am copying with mouse a lets say 5 lines to clipboard in mcedit, in which each line contains only (for example) 10 valid characters on the beginning, then it will copy the full lines filling the empty space at the and with whitespaces.
Doing the same thing in putty copies only valid characters to clipboard.

Copying the same line in vim copies only tha valid characters (10 chars) to clipboard in shell and in putty as well.

How can i force xshell to copy only valid characters in mcedit. Is this a bug or a feature?

Thanks,
Todvard.


Program Ver. : Xshell 3.0
Monday, May 26, 2008 6:24 PM - Support

Re: copying to clipboard with mouse

 
Thank you for the report. We have notice the problem and it has been reported.

Meanwhile, could you tell us the following information for more accurate testing?

1. TERM type (result of 'echo $TERM')

Thank you.


---
Technical Support
Tuesday, May 27, 2008 4:11 AM - Todvard

Re: Re: copying to clipboard with mouse

 
Hi,

here is the term env variable:

joe@isp:~$ echo $TERM
xterm

Best,
Todvard
Wednesday, May 28, 2008 12:09 PM - Support

Re: Re: Re: copying to clipboard with mouse

 
Thank you for the information. We will include a fix in the future releases.

I will let you know when the fix becomes available.

---
Technical Support
Wednesday, March 9, 2016 2:24 AM - Jignesh

Re: copying to clipboard with mouse

 
Hello,

Dose this fixed? I am getting same issue.. it's not copy + pest correct text as putty do

Regards,
Jignesh
Thursday, March 10, 2016 8:58 PM - Support

Re: copying to clipboard with mouse

 
The copying of empty space issue was fixed. Have you updated Xshell? Can you explain more in detail what issue you are facing?

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog