Xshell Forum

Issue with 'Backspace' and 'Delete' Keys

Last post: Thursday, April 24, 2008 6:37 PM by Support, 17 reply

 
Tuesday, March 18, 2008 11:48 PM - Pravat

Issue with 'Backspace' and 'Delete' Keys

 
Am using Xshell 3.0 on Vista Ent. When connected to a AIX host the 'Backspace' and 'Delete' Keys doesn't work as desired.

But for the same putty work pretty fine. Tried all the options in Terminal > Keyboard, none of them helped.

Putty config and the xshell build screenshots attached.


Program Ver. : Xshell 3.0
Wednesday, March 19, 2008 4:55 PM - Morfio

Re: Issue with 'Backspace' and 'Delete' Keys

 
Delete doesn't work in most shell environment. You can try this on console. I have tried with Putty too but the delete doesn't work there either.

However, backspace key works if the backspace option is set as 'Backspace (Ctrl+H)' in Properties > > Terminal > Keyboard.

Thursday, March 20, 2008 1:08 AM - Pravat

Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
It does delete but the text shows up as it is... check the attached screenshot for a clear idea...
Thursday, March 20, 2008 6:03 PM - Support

Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
Thank you for using Xshell.

We have tested on AIX 5.3 but the problem did not occur.

Please try de-selecting the 'Insert Mode (IRM)' option in Terminal > VT mode.

Also, if your problem persists, please send us the following information:

1. Terminal Type
2. Language

Thank you.


---
Technical Support
Thursday, March 20, 2008 11:22 PM - Pravat

Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
Problem remains the same.
Screenshots attached.
Thursday, March 20, 2008 11:38 PM - Support

Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
For terminal and language encoding type, please send us the outputs of the following commands:

In terminal screen, give

1. For terminal type: echo $TERM
2. For language setting: echo $LANG

Thank you.

---
Technical Support
Friday, March 21, 2008 4:39 AM - Pravat

Re: Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
$ echo $LANG
en_US

$ echo $TERM
xterm
Friday, March 21, 2008 4:33 PM - Support

Re: Re: Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
This problem can occur when echo is turned off in ksh. Try giving the following command:

$ stty echoe

Hope this helps.

---
Technical Support



Friday, March 21, 2008 11:49 PM - Pravat

Re: Re: Re: Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
Doesn't work either...
Monday, March 24, 2008 6:01 PM - Support

Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
This problem could not be duplicated. Since we are testing this on a same AIX machine, I am almost certain that this is probably a configuration problem. Please post the result of 'stty -a'

Also, could you confirm that backspace functions as normal in Putty?

It would help us solving this problem if you can provide us with a test account on the AIX machine. If you can, please send us the account and server information to support@netsarang.com.

---
Technical Support







Monday, March 24, 2008 11:13 PM - Pravat

Re: Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
in Xshell 3.0
--------------------------------------
$ stty -a
speed 38400 baud; 29 rows; 103 columns;
eucw 1:1:0:0, scrw 1:1:0:0:
intr = ^C; quit = ^\; erase = ^H; kill = ^U; eof = ^D; eol =
eol2 = ; start = ^Q; stop = ^S; susp = ^Z; dsusp = ^Y; reprint = ^R
discard = ^O; werase = ^W; lnext = ^V
-parenb -parodd cs8 -cstopb -hupcl cread -clocal -parext
-ignbrk brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl -iuclc
ixon -ixany -ixoff -imaxbel
isig icanon -xcase echo -echoe -echok -echonl -noflsh
-tostop -echoctl -echoprt -echoke -flusho -pending -iexten
opost -olcuc onlcr -ocrnl -onocr -onlret -ofill -ofdel tab3
--------------------------------------


in Putty
--------------------------------------
$ /usr/bin/stty -a
speed 38400 baud; 21 rows; 80 columns;
eucw 1:1:0:0, scrw 1:1:0:0:
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol =
eol2 = ; start = ^Q; stop = ^S; susp = ^Z; dsusp = ^Y; reprint = ^R
discard = ^O; werase = ^W; lnext = ^V
-parenb -parodd cs8 -cstopb -hupcl cread -clocal -parext
-ignbrk brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl -iuclc
ixon -ixany -ixoff -imaxbel
isig icanon -xcase echo -echoe -echok -echonl -noflsh
-tostop -echoctl -echoprt -echoke -flusho -pending -iexten
opost -olcuc onlcr -ocrnl -onocr -onlret -ofill -ofdel tab3
--------------------------------------

Yes, Backspace works fine in Putty.
Tuesday, March 25, 2008 3:54 AM - Pravat

Re: Re: Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
THIS HAS TO BE FIXED ASAP...

Now, I have found another AIX box where for root user the Backspace works pretty fine but it doesn't work for other users...


As root:
--------
$ stty -a
speed 9600 baud; 31 rows; 124 columns;
eucw 1:1:0:0, scrw 1:1:0:0:
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = ^@
eol2 = ^@; start = ^Q; stop = ^S; susp = ^Z; dsusp = ^Y; reprint = ^R
discard = ^O; werase = ^W; lnext = ^V
-parenb -parodd cs8 -cstopb hupcl cread -clocal -parext
-ignbrk brkint ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl -iuclc
-ixon -ixany -ixoff imaxbel
isig icanon -xcase echo echoe echok -echonl -noflsh
-tostop echoctl -echoprt echoke -flusho -pending iexten
opost -olcuc onlcr -ocrnl -onocr -onlret -ofill -ofdel tab3

$ echo $TERM
vt220

$ echo $LANG
en_US



As normal user:
---------------
$ stty -a
speed 9600 baud; 31 rows; 124 columns;
eucw 1:1:0:0, scrw 1:1:0:0:
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = ^@
eol2 = ^@; start = ^Q; stop = ^S; susp = ^Z; dsusp = ^Y; reprint = ^R
discard = ^O; werase = ^W; lnext = ^V
-parenb -parodd cs8 -cstopb hupcl cread -clocal -parext
-ignbrk brkint ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl -iuclc
-ixon -ixany -ixoff imaxbel
isig icanon -xcase echo echoe echok -echonl -noflsh
-tostop echoctl -echoprt echoke -flusho -pending iexten
opost -olcuc onlcr -ocrnl -onocr -onlret -ofill -ofdel tab3

$ echo $LANG
en_US

$ echo $TERM
xterm
Wednesday, March 26, 2008 4:18 PM - Support

Re: Re: Re: Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
You must enable echoe and echoctl values. You can do this by using the following commands:

stty echoe
stty echoctl


---
Technical Support



Thursday, March 27, 2008 11:52 AM - Pravat

Re: Re: Re: Re: Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
I tried adding the following to the user's .profile. It works for the current session, even works for the session with "su", but no help when we switch user with it's environment "su -".

$ tail -3 .profile
stty echoe
stty echoctl
stty erase ^H


If i have to enable echoe and echoctl values to make the Backspace to work as desired, how come a free client like putty currently working fine? Hence I won't be able to add the 'echoe and echoctl' to the global profile file.
Thursday, March 27, 2008 4:01 PM - Support

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
Our developers are working on this and we will release a patch for this feature in the near future. I will let you know the earliest when the patch is released.

Thank you for your patience.

---
Technical Support
Tuesday, April 15, 2008 8:32 PM - Pravat

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
When this patch coming in?
Wednesday, April 16, 2008 10:45 AM - Support

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
This feature will be included in the next release. We will send you an email when this become available.

Thank you for your patience.


---
Technical Support
Thursday, April 24, 2008 6:37 PM - Support

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Issue with 'Backspace' and 'Delete' Keys

 
This feature has been added in the latest release. You can download it at:

/download/main.html

This option, ?Destructive backspace?, can be found in Terminal > Advanced in the session properties. Please make sure to set the backspace key as ?ASCII 127 (Ctrl+?)?.

---
Technical Support