Xshell Forum

Disable auto-scroll

Last post: Thursday, August 2, 2018 3:05 PM by Support, 3 reply

 
Friday, July 13, 2018 7:07 PM - Bjoern

Disable auto-scroll

 
Hej all,

currently Xshell always auto scrolls when there is an update in the terminal. Sometimes you are executing a program and you want to examine its output while it is running and producing more output. If you want to inspect a particular line while the program is still running and producing output, Xshell always scrolls down automatically which can be very annoying.

I am looking for a way to prevent Xshell to jump back down on a terminal update when I scrolled up to look at some output.

A button with "disable auto-scroll" would be awesome.

Or does this exist somewhere already?

Greetings,
Bjoern

Program Ver. : Xshell 6
Monday, July 16, 2018 3:46 PM - Support

Re: Disable auto-scroll

 
Xshell has a couple options which should solve your issue. Try changing the following options in your session's properties.

Turn OFF "Scroll to the bottom when terminal input/output"
Turn ON "Scroll to the bottom when a key is pressed"

These options can be found at: Session Properties -> Terminal -> Advanced.

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog
Tuesday, July 31, 2018 12:23 PM - Bjoern

Re: Disable auto-scroll

 
Thanks!

I didn't search in the session settings. I thought I remembered it to be a global setting on Xshell 5

Would though be nice to have a button somewhere to quickly enable/disable the option :)

Thanks!

Cheers,
Bjoern
Thursday, August 2, 2018 3:05 PM - Support

Re: Disable auto-scroll

 
I agree that a quicker way to enable/disable the feature would be helpful. I've reported this to our dev team for review. Thanks!

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog