Xshell Forum

zlib compression not working with ssh

Last post: Friday, June 15, 2018 7:50 AM by charlie2alpha, 4 reply

 
Wednesday, May 30, 2018 8:23 AM - charlie2alpha

zlib compression not working with ssh

 
Hello,

I upgraded today to XShell 6, selected to migrate my user data to the new version (I was using XShell 5) and I immediately faced a connection problem.

Specifically, I could not connect via ssh to my remote server. After many attempts I discovered that I can connect if I disable the zlib compression option.

Things I tried: I tried the same server with Xshell 5 and zlib compression, it works. I tried with putty and compression enabled, it works.

This is a bug with Xshell 6, since even Xshell 5 has not issue with compression but Xshell 6 fails to progress beyond the "Connection established.
To escape to local shell, press 'Ctrl+Alt+]'." message. It just hangs there and I have to close the connection tab as the keyboard won't work.

Program Ver. : Xshell 6
Friday, June 1, 2018 12:39 AM - Support

Re: zlib compression not working with ssh

 
This is not a general issue with Zlib. Can you please let us know the following information related to your remote server:

1. UNIX/Linux type and version.
2. If you installed the ssh server and customized it, we'll need to know the package and version.
3. Xshell's connection log. You need to turn on related options in the session properties. Advanced -> Trace -> Protocol Events.

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog
Friday, June 1, 2018 1:30 PM - charlie2alpha

Re: zlib compression not working with ssh

 
Here is the info you asked for:

1. Gentoo Linux, amd64. No version exists, it is a rolling distribution. All packages are updated at this moment to their latest stable versions.

2. I configured the server myself, version net-misc/openssh-7.5_p1-r4. Compression is set to the default (delayed) but I believe it is a synonym for "on" in this version.

3. Connection log can be found here: https://pastebin.com/JJsPkmss
Tuesday, June 5, 2018 1:50 AM - Support

Re: zlib compression not working with ssh

 
Thanks for the information. We'll further investigate this issue.

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog
Friday, June 15, 2018 7:50 AM - charlie2alpha

Re: zlib compression not working with ssh

 
My problem has been solved after I received an update to openssh, the Gentoo Linux version of openssh is now net-misc/openssh-7.7_p1-r4 and it works with XShell's zlib compression.