Xshell Forum

Xshell v5 performence

Last post: Friday, December 15, 2017 4:53 PM by Nick, 4 reply

 
Monday, December 4, 2017 2:34 PM - Nick

Xshell v5 performence

 
Can someone please help explain why xshell becomes really slow if I enabled the capacity to detach/re-attach tabs?

Program Ver. : Xshell 5
Tuesday, December 5, 2017 5:36 PM - Support

Re: Xshell v5 performence

 
There seems to be some issues with Windows 10 Red stone 3. This problem is not unique to Xshell, but we are continuing to investigate. We believe your issue is related.

For now, try using Xshell's single process mode by going to Tools -> Options -> Advanced tab -> 'Use single-process mode for better performance.'

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog
Tuesday, December 5, 2017 5:58 PM - Nick

Re: Xshell v5 performence

 
I would not agree on that actually. I also tested with another similar application called MobaXterm and it doesn't have the slowness for feature detaching/reattaching tabs.
Thursday, December 14, 2017 6:34 AM - Sean S

Re: Xshell v5 performence

 
After the 2nd to most recent update (currently at Build 1337) the speed of opening a new tab increases almost exponentially with each new tab that's opened.

In the past I've noted that XShell is very sensitive to disk IO performance. Likely a result of me having "Start logging upon connection" on as default. Or maybe due to me having so many Sessions, currently 2247 items in 126 folders/sub-folders.
Friday, December 15, 2017 4:53 PM - Nick

Re: Xshell v5 performence

 
Do you have "Use single-process mode for better performance" unchecked in advanced tab under Options?

I just tried it again with v1337 and does seems to be slightly faster but not whole alot...