Xshell Forum

Extra space after characters

Last post: Thursday, January 3, 2008 3:01 PM by Support, 4 reply

 
Friday, December 21, 2007 8:53 PM - Paul Lebedev

Extra space after characters

 
Russian letters and some line drawing characters are displayed with an extra space after them, as seen on the screenshot. Server is using UTF-8 (and UTF-8 is selected in connection properties). XShell 3.0 Beta 0184.
Attachment XShell.PNG (39.5 KB)  
Monday, December 24, 2007 2:25 PM - Lank Blair

Re: Extra space after characters

 
As far as I know, mc(midnigt commander) usually doesn't support UTF8 encoding.

Try using non-utf8 encodings.

Monday, December 24, 2007 9:07 PM - Paul Lebedev

Re: Re: Extra space after characters

 
The same happens on the plain shell, it's just an example. And PuTTY doesn't have this problem.
Attachment Compare.PNG (23 KB)  
Wednesday, December 26, 2007 2:04 PM - Support

Re: Re: Re: Extra space after characters

 
Thank you for your report. We have found the problem and fixed it. We will release the updated edition soon.


---
Technical Support

Thursday, January 3, 2008 3:01 PM - Support

Re: Re: Re: Re: Extra space after characters

 
This problem has been fixed in Xshell 3.0 Build 0189. Please try updating your Xshell.

To remove spaces between the characters, open the session properties dialog box and click Terminal from the Category menu. In the Translation area, select Unicode (UTF-8) for encoding, and then clear the "Treat CJK ambiguous characters as wide" option.

Thank you for participating in Xshell beta testing.

---
Technical Support