Xshell Forum

Too many authentication failures for *username*

Last post: Thursday, January 26, 2017 9:34 PM by Support, 1 reply

 
Monday, January 23, 2017 12:02 AM - Hezt

Too many authentication failures for *username*

 
I use Multiple public keys , and I have enabled Xagent. When I connect some of servers, I can't connect and got error message from Xshell:

"The server sent a disconnect packet.
Too many authentication failures for "username" (code: 2)"

By the tcpdump tool, the number of errors exceeded the limit of MaxAuth,
There have been problems in the xshell3 version,Is this issue fixed in the xshell5 version?

Program Ver. : Xshell 5
Thursday, January 26, 2017 9:34 PM - Support

Re: Too many authentication failures for *username*

 
This is not a bug. The key service of Xagent applies the value of private keys one by one until a match is found. However, SSH servers only allow a limited number of attempts.

You can try one of the following options:

1. Designate a proper key file in your sessions.
2. Minimize the public keys in your private key list.
3. Increase the MaxAuthTries value. Default for OpenSSH is 6.

We'll continue to think of better features in Xagent to increase ease of use.

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog