Xshell Forum

keep-alive not work

Last post: Tuesday, November 13, 2007 6:08 PM by Support, 3 reply

 
Monday, November 12, 2007 6:05 PM - bandw

keep-alive not work

 
When I have been connected to server a, then ssh to b, after some minutes, it was disconnected to b, back to a.I don't know what message xshell sends to keep alive, but it seems not work.
Can user set what the message is just like secureCRT?
Tuesday, November 13, 2007 11:50 AM - Support

Re: keep-alive not work

 
The problem is that KeepAlive signal can only reach to the intermediary server (server A).

To keep the connection open between server A and server B, in server A, set the TCPKeepAlive value to 'yes' in /etc/ssh/ssh_config.

And, currently Xshell does not support sending user defined characters to keep the connection open. But, the feature has been added to our requested features list and we hope to bring this feature to life soon.


---
Technical Support
Tuesday, November 13, 2007 5:19 PM - bandw

Re: Re: keep-alive not work

 
Thanks for your reply, it's very usefull for me.
By the way, I also want to say someting about "new file transfer", when I ssh to server B across A,click "new file transfer", the window opened(xftp) was still at A,I can't transfer any file of B.
Tuesday, November 13, 2007 6:08 PM - Support

Re: Re: Re: keep-alive not work

 
Thank you for your request.

For now, there is no way of knowing the information of the destination server from the terminal emulator when connected through a intermediary server. However, we will take your idea into consideration for building our future products..


---
Technical Support