Xshell Forum

problem using short-cut characters in xemacs (XShell 2.0)

Last post: Saturday, November 10, 2007 1:01 AM by Andrew Johnson, 1 reply

 
Friday, November 9, 2007 11:19 PM - Fabrizio Salvatore

problem using short-cut characters in xemacs (XShell 2.0)

 
Hi,

I have XManager Enterprise 2.0, with XShell 2.0. I use XShell to connect to a central linux box in my institution. Here I use xemacs as an editor. I noticed that some of the short-cut characters in xemacs do not work: for example, to 'Replace' a string, the short-cut ' ALT % ' (that is also suggested in the drop-down box that opens up clicking on the 'Edit' tab of the xemacs window) does not have any effect. Is this a 'feature' of xshell ? When I first installed Xshell on my XP laptop I had to define do the following

setenv LANG C

on all the linux boxes I wanted to connect using XShell, in order to cure some problems I had with the fonts in xemacs. Is this some sort of 'simular' problem ? Do I need to define some envvar for enabling some of the short-cuts ? BTW, other short-cuts (CTR^X CRT^S to save without exiting, for instance) do work fine...

Thanks for your help,

Fabrizio

Saturday, November 10, 2007 1:01 AM - Andrew Johnson

Re: problem using short-cut characters in xemacs (XShell 2.0)

 
Perhaps I can shed some light on this matter.

Open Session properties and in the Terminal tab, select Use Alt as Meta key.

According to Xshell manual when this option is selected, you cannot access Xshell menus using the Alt key.