Xshell Forum

Mouse scroll in VIM

Last post: Tuesday, March 1, 2016 3:27 AM by Lin, 5 reply

 
Monday, February 15, 2016 9:10 AM - Lin

Mouse scroll in VIM

 
When I upgrade to build 0896 from previous version.

I cannot use mouse to scroll in VIM.

Program Ver. : Xshell 5
Wednesday, February 17, 2016 3:37 AM - Support

Re: Mouse scroll in VIM

 
I've tried to replicate this issue in Build 0896, but I was unable to do so.

Have you tried the 'set mouse=a' command in VIM? Check if the mouse mode is enabled using 'set mouse?'
Wednesday, February 17, 2016 5:38 AM - lin

Re: Mouse scroll in VIM

 
Yes, I have set mouse=a in my .vimrc before.

I test with Putty or MobaXterm these two windows terminal software. They works very well.
Is there any Xshell's setting possible broken in my Windows after upgrade to the latest version?
Saturday, February 27, 2016 12:38 AM - Support

Re: Mouse scroll in VIM

 
Try checking to see if the terminal type of the Xshell session and your TERM environment after login is set to xterm. I've attached a photo for reference.

$echo $TERM
xterm

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog
Saturday, February 27, 2016 12:55 AM - Support

Re: Mouse scroll in VIM

 
Oops. Forgot to attach the photo. I've done so here.

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog
Attachment image.png (43.8 KB)  
Tuesday, March 1, 2016 3:27 AM - Lin

Re: Mouse scroll in VIM

 
Thanks!
I am not sure why my original setting has changed to 'linux'.
After change to 'xterm', it works very well.