Xshell Forum

Xshell never prompts for password / login fails

Last post: Tuesday, December 22, 2015 12:48 AM by Support, 3 reply

 
Wednesday, December 9, 2015 8:34 PM - weheartwebsites

Xshell never prompts for password / login fails

 
Since the recent update, Xshell does not work with username:password authenticated SSH.

It will ignore any connection string that contains a password and instead cycle through all available public keys from Xagent.

Only once I deactivate Xagent it works.

Program Ver. : Xshell 5
Thursday, December 17, 2015 1:58 AM - Support

Re: Xshell never prompts for password / login fails

 
If you enable the "Use Xagent (SSH Agent) for handling passphrase" option, Xshell will try to use Xagent even if a user wants to use password authentication. In this case, Xagent services a large number of keys and the connection can fail because of the retry time setting of the server. Many systems allow 5 retries of key authentication by default.
Attachment image.png (47 KB)  
Thursday, December 17, 2015 10:38 AM - weheartwebsites

Re: Xshell never prompts for password / login fails

 
ah, so best is most probably to keep it unchecked? Even if you are using key auth it would be better to explicitly just set it?
Tuesday, December 22, 2015 12:48 AM - Support

Re: Xshell never prompts for password / login fails

 
We've discovered a slight issue with Xagent's mechanism. Though the 'Use Xagent' option is checked, when password authentication is selected Xshell will try to login with the password.

We will release a fix for this as soon as possible.