Xshell Forum

Local shell can't use number keypad

Last post: Monday, May 16, 2016 9:57 PM by Support, 5 reply

 
Wednesday, September 16, 2015 10:32 PM - bak724

Local shell can't use number keypad

 
Can't use number keypad in localshell mode except "." in the lastest version

Program Ver. : Xshell 5
Thursday, September 17, 2015 5:19 AM - Support

Re: Local shell can't use number keypad

 
We have already fixed this issue and it will be included in the next release.


Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog
Monday, September 28, 2015 1:03 AM - refuge

Re: Local shell can't use number keypad

 
0706 and 0738 cannot use number keypad
Tuesday, October 6, 2015 10:24 AM - Support

Re: Local shell can't use number keypad

 
We are testing the release candidate now. It will take just a little bit more time.


Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog
Wednesday, May 11, 2016 6:54 PM - Elias pIZARRO

Same issue

 
doesn't work xshell 5 0959
Monday, May 16, 2016 9:57 PM - Support

Re: Local shell can't use number keypad

 
This issue is related to your TERM environment. If you are using Vim, the TERM env must be sent to ansi. However, the ansi TERM env may cause problems in certain conditions.

I've attached a photo of Xshell's settings which show how to change your Initial Numeric Keypad Mode which may resolve your issue.

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog
Attachment image.png (25 KB)