Xshell Forum

Backspace not working on Y/n prompts

Last post: Friday, January 22, 2016 1:08 AM by Support, 9 reply

 
Thursday, September 3, 2015 9:16 AM - weheartwebsites

Backspace not working on Y/n prompts

 
Reproducing steps:

* connect to Ubuntu 14.04 server via ssh
* run $ sudo apt update
* run (only works if there are upgradable packages) $ sudo apt upgrade
* type in anything and use "Backspace" to delete it again. Instead of deleting previous chars it will add some weird chars

Program Ver. : Xshell 5
Wednesday, September 9, 2015 9:27 AM - Support

Re: Backspace not working on Y/n prompts

 
Firstly, upgrade to the latest version by selecting the Check for updates in the Help menu.

Then, if the problem persists, please send us the following information:

1. When this problem occurs, try resetting the terminal by selecting Edit > Reset Terminal. Does this fix the problem?
2. What is remote terminal type and shell? Send us the result of 'echo $TERM' and 'echo $SHELL'.




Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog
Thursday, September 10, 2015 2:54 AM - weheartwebsites

Re: Backspace not working on Y/n prompts

 
Resetting terminal did not make any difference


$ echo $TERM; echo $SHELL
xterm
/bin/bash
Monday, September 14, 2015 8:54 AM - Support

Re: Backspace not working on Y/n prompts

 
Did you upgrade to the latest version? Similar problem has been fixed in the earlier releases.


Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog
Thursday, September 17, 2015 1:27 PM - weheartwebsites

Re: Backspace not working on Y/n prompts

 
Yes, see attachment.
Friday, September 25, 2015 3:14 AM - David

Re: Backspace not working on Y/n prompts

 
This problem is caused by missing readline support.

Some applications bind delete key to ^H. nslooup often has this issue.

Try using Ctrl+H key combination. If you must use the backspace key, read this article:

https://www.netsarang.com/forum/xshell/3265/
Saturday, September 26, 2015 7:59 AM - weheartwebsites

Re: Backspace not working on Y/n prompts

 
Thanks David! Though why does it work with other SSH clients without problems?
Tuesday, October 6, 2015 10:22 AM - Support

Re: Backspace not working on Y/n prompts

 
Can you capture the steps to reproduce the problem by using psr.exe and send it back to us? It will help us resolve this problem faster. Please send the file to support@netsarang.com.


Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog
Tuesday, January 19, 2016 8:40 AM - weheartwebsites

Re: Backspace not working on Y/n prompts

 
This is still a huge issue.

You can replicate this on any Ubuntu/Debian server, anywhere where there is a Y/n prompt it will not work using the backspace key to correct your entered value.
Friday, January 22, 2016 1:08 AM - Support

Re: Backspace not working on Y/n prompts

 
Can you try reading over this KB article here and let me know if this resolves your issue:

https://www.netsarang.com/knowledgebase/xshell/3630/Backspace_not_Recognized

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog