Xshell Forum

supporting to chinese is too bad

Last post: Monday, July 9, 2007 11:17 AM by Anthony Zhang, 5 reply

 
Saturday, July 7, 2007 11:16 AM - huili

supporting to chinese is too bad

 
Sir:
I'm from china, i like xshell, because the multi_document interface, and the power function of the software, but it did not support the chinese, if you use the neterm, you will find netterm suppport chinese well, hope you refer the netrerm software, and increase the xshell.
question: when inputting chinese words(use vi) display mass code, after press (ctrl+l) the display is ok.
Saturday, July 7, 2007 12:47 PM - Bambo Huang

Re: supporting to chinese is too bad

 
Generally Simplified Chinese Windows system use zh_CN.GB2132 code but your Unix/Linux system's console's default code maybe is zh_CN.UTF-8 or others. Try "export LANG=zh_CN.GBK" or "export LANG=zh_CN.GB2312" to set your code env and try it again.
Tuesday, July 10, 2007 3:37 PM - huili

Re: Re: supporting to chinese is too bad

 
why netterm can work ok without setting anything?
the Unix system that I used don't have the code that you list,in this conddtion, what can i do?
problem:it can display chinese ok, but when you input chinese in VI,between two chinese words, it display mass code.
hope someone can give me some advice,thanks a lot!
Tuesday, July 10, 2007 6:28 PM - Support

Re: Re: Re: supporting to chinese is too bad

 
Thank you for using Xshell.

This problem may occur when the encoding setting and font is not selected properly. To fix this:

1. Find out the LANG value of your terminal
$ echo $LANG

2. Depending on your LANG value, select an appropriate Xshell encoding such as Unicode-UTF-8, Chinese-Simplified, or Chinese-Traditional.
Note: To select an encoding type, click on the globe icon on the Xshell toolbar.

3. Select an appropriate font for your encoding type such as NSimSun or MingLiu.

If your problem persists, please send us the following information:

1. Name/version of UNIX and vi editor
2. LANG value
3. Screenshot of the problem.

Thank you for your cooperation.


---
Technical Support
Friday, July 13, 2007 3:01 PM - huili

THANKS

 
thank you for your help,I think this problem can't be fixed in such short time,I used xshell2.0 product, and it works better than xshell3.I'm from china,and as I know much people used NETTERM,because it works good in chinese,maybe you can use netterm and find sth different.
thank you for your help.
good luck!
Monday, July 9, 2007 11:17 AM - Anthony Zhang

Re: Chinese works well for me!

 
I was using Xshell 2.0 and now 3.0 beta, but Chinese works ok for me.

Try playing with your server's LANG value and the encoding setting in Xshell to match each other.


Or, post how readers can duplicate the problem. Maybe someone can help you.