Xshell Forum

ALT+Backspace giving a annoying Bell Sound.

Last post: Friday, March 20, 2015 2:28 AM by Support, 4 reply

 
Thursday, February 12, 2015 10:51 PM - Nags

ALT+Backspace giving a annoying Bell Sound.

 
I use ALT+Backspace to delete words to the left of my cursor in a terminal. This used to work fine in PuTTY. I recently installed Xshell.

Initially the Backspace was giving Crtl+H as default. I changed it to ASCII 127 (Crtl+?).This works, it deletes words left of my cursor. But it gives a annoying Bell sound whenever I use. I tried disabling the Bell from the 'Options->Advanced-Disable Bell'. But it doesn't seem to have any effect.

Is this a bug or should I do something else to disable the Bell ? Or have I configured it wrong ? Please help .

Note: I have enabled 'Use ALT key as Meta key' option as i'm a emacs user.

Program Ver. : Xshell 5
Friday, February 13, 2015 4:05 PM - Support

Re: ALT+Backspace giving a annoying Bell Sound.

 
Xshell only plays the sound when the remote servers sends sound request.

You should be able to delete characters with just backspace key. Is there any reason you are using alt-backspace instead of just backspace?

---
Technical Support
Thursday, February 26, 2015 7:25 AM - jun

Re: ALT+Backspace giving a annoying Bell Sound.

 
I meet the same problem. I used to use alt+backspace to delete the whole word in putty which is very very quick and convienent.

but in xshell, it's not supported, if I want to delete one word, I need to press backspace several times.
Thursday, March 5, 2015 4:46 AM - Support

Re: ALT+Backspace giving a annoying Bell Sound.

 
We found the problem and fixed it. You can refer to this case with its case #, 3015. Fix should be included in the next release.


---
Technical Support
Friday, March 20, 2015 2:28 AM - Support

Re: ALT+Backspace giving a annoying Bell Sound.

 
This problem has been fixed in the latest release (2015/3/20).

---
Technical Support