Xshell Forum

Systems Analyst

Last post: Tuesday, May 15, 2007 11:32 AM by Support, 8 reply

 
Tuesday, May 8, 2007 9:40 AM - Alf Pearce

Systems Analyst

 
I have been evaluating XShell 3.0 Beta for some time in conjunction with our licenced copy of XManager 2.0 (licence key xxxxxx), mainly to use the XAgent tool. This has been working very well so far.

However, this morning when I started XShell I was advised that the licence had expired and was invited to re-install a new copy of XShell 3.0 Beta. I downloaded the latest version, uninstalled the old version, and installed the new version. Everything seemed to work well.

I was able to start XAgent and see that my saved key was still accessible. I also took the opportunity to reset the passphrase on the key.

I stopped the agent and then started one of my saved XManager sessions which brought up a prompt for the passphrase of the saved key. I entered the passphrase and the session started normally. However, the XAgent was not started. So for each subsequent session that I started, I was again prompted for the passphrase of the key.

I then tried starting the XAgent first, followed by various XManager sessions that were to be authenticated using the saved key. Even with the XAgent running, I was still prompted for the passphrase of the key to start each session.

Is this a problem in the latest version of XShell 3.0 Beta, or is there something that I might have missed in the setup when re-installing XShell? Any advice in getting this working properly again would be greatly appreciated.
Tuesday, May 8, 2007 2:18 PM - Support

Re: Systems Analyst

 
Thank you for using Xmanager.

Please check if your Xmanager sessions are setup with 'Use SSH authentication agent (Xagent)' option selected. To check this, open the SSH Protocol Setup dialog box by clicking Setup next to the Protocol list in their properties.

If your problem persists, please provide us the following information:

- Screenshot of the Passphrase dialog box
- All reply messages in the 'Xrcmd: reply message' dialog box.

Hope this solves your problem.

---
Technical Support
Tuesday, May 8, 2007 5:23 PM - Alf Pearce

Re: Re: Systems Analyst

 
The saved sessions are definitely set up to use the Xagent. I have been using them this way for several months quite successfully. Only after the licence expired on my old Xshell 3.0 Beta and I reinstalled the latest version this morning did this stop working.

The authentication popup that I am getting now is different to the one I had seen previously.

The screen shots that you asked for are in the attached file.

Alf.
Tuesday, May 8, 2007 6:09 PM - Support

Re: Re: Re: Systems Analyst

 
Please upgrade your Xmanager 2.0 to the most recent version (Build 0740) available at:

/download/main.html

If your problem persists, please provide us all reply messages in the 'Xrcmd: reply message' dialog box. (In order to open this box, 'Show reply messages from the remote host' option should be selected in the session properties.)

Hope this solves your problem. Your feedback is greatly appreciated.

---
Technical Support
Wednesday, May 9, 2007 9:21 AM - Alf Pearce

Re: Re: Re: Re: Systems Analyst

 
After upgrading Xmanager 2.0 to the latest build, the behaviour has remained unchanged. As you suggested, I set two of my Xstart sessions to show reply messages and then did the following tests, saving the reply messages each time:

1. Start a session without Xagent running by supplying the passphrase of my saved key for authentication. This did not result in an Xagent being started, but the session itself did start properly.

2. Start a second session without Xagent running by again supplying the passphrase of my saved key. This session also started properly.

3. Stop the two sessions started above and close Xmanager.

4. Start Xagent from Xshell 3.0 Beta. This showed that the agent was running on the default port 5435, and that the status of the key was "closed".

5. Start a session with Xagent running on port 5435 but with the key closed, again by supplying the passphrase of the saved key. This started successfully, but the status of the key remained set to "closed".

6. Start a second session with these same conditions by supplying the passphrase of my saved key. This session also started successfully, but again the status of the key remained as "closed".

7. In the agent, right click on the key and select Open, resulting in a popup to supply the passphrase of the key. The passphrase was successfully entered and the status then showed as "open".

8. Close the two sessions and Xmanager.

9. Start a session with Xagent running on port 5435 and with the key showing a status of "open". This still required the entry of the passphrase again in order to complete the authentication to get the session started successfully.

10. Start a second session with Xagent running and key open. This still required the entry of the passphrase to complete authentication for the session.

Clearly, Xmanager is no longer communicating with Xagent.

The Xrcmd outputs from these six session startups are in the attached text file (Notepad).

Alf.
Wednesday, May 9, 2007 10:57 AM - Support

Re: Re: Re: Re: Re: Systems Analyst

 
We have duplicated this problem and it has been reported to our developers.

We will get back to you in a couple of days with a patch for this problem.

Thank you for your patience.

---
Technical Support
Friday, May 11, 2007 11:23 AM - Support

Re: Re: Re: Re: Re: Systems Analyst

 
Thank you for your patience.

The problem has been fixed. Please upgrade your Xmanager 2.0 to the most recent version (Build 0750) available at:

/download/main.html

Hope this solves your problem. Your feedback is greatly appreciated.

---
Technical Support
Tuesday, May 15, 2007 8:07 AM - Alf Pearce

Re: Re: Re: Re: Re: Re: Systems Analyst

 
I have upgraded to Xmanager 2.0 build 0750 as suggested, and can confirm that this does indeed fix the problem of not working with Xagent from Xshell 3.0 beta build 0084. Thanks very much for the prompt resolution.

Alf.
Tuesday, May 15, 2007 11:32 AM - Support

Re: Re: Re: Re: Re: Re: Re: Systems Analyst

 
We are glad that it solved your problem. Please let us know if we can be of further assistance.

---
Technical Support