Xshell Forum

backspace non-english UTF-8 chars bug

Last post: Friday, January 23, 2015 7:06 PM by Support, 1 reply

 
Thursday, January 22, 2015 12:11 AM - mixer

backspace non-english UTF-8 chars bug

 
1. type text in UTF-8 non-english encoding (Russian in my case)
2. try delete text by backspace key (press and hold)

result: xshell delete more chars than needed

Program Ver. : Xshell 4
Friday, January 23, 2015 7:06 PM - Support

Re: backspace non-english UTF-8 chars bug

 
There are few things you can to check:

1. Did you set the Xshell terminal encoding to UTF-8? If not, you can do this in the Xshell toolbar. Click the Globe icon and select Unicode (UTF-8).

2. Did you get the remote terminal settings to UTF-8? If not, set the remote terminal encoding to ru_RU.utf8.

3. Try disabling the Treat CJK ambiguous characters as wide character option in the Terminal > Translation option (in the session properties).




---
Technical Support