Xshell Forum

Title is not updated in Session Tab

Last post: Wednesday, January 21, 2015 5:10 AM by Shuai, 9 reply

 
Wednesday, October 1, 2014 6:04 AM - Shuai

Title is not updated in Session Tab

 
This has been an issue since the beginning of the beta of Xshell 5.

I have a session saved with name CORE-SW inside Xshell. Everytime I connect to CORE-SW, the title of the tab changed to CORE-SW which is great and I want that. However when I exist the connection back to the local shell, the title is still showing CORE-SW for the tab. It should switch back displaying "Local Shell" in My opinion. The same for the main window title as well, unless I open another tab.

This is not critical but annoying...Running the latest beta now.

Program Ver. : Xshell 5
Wednesday, October 1, 2014 6:30 PM - Support

Re: Title is not updated in Session Tab

 
This is actually an intended feature. There were other users who has been using different session names and when the connections are broken abruptly, all tabs change to local shell. So, some users were saying that we should keep the session name even after it disconnects.

I will definitely bring this subject during our next developers meeting and try to find a solution.

---
Technical Support
Sunday, October 5, 2014 3:27 PM - Shuai

Re: Title is not updated in Session Tab

 
Okey, maybe there could be a configuration option to enable or disable it?
Sunday, October 5, 2014 7:06 PM - Support

Re: Title is not updated in Session Tab

 
We are discussing about switching back to the original. Sorry for the inconvenience.

---
Technical Support
Tuesday, October 28, 2014 12:29 PM - Shuai

Re: Title is not updated in Session Tab

 
I think this is now fixed in lastest beta.
Friday, January 9, 2015 6:26 AM - Shuai

Re: Title is not updated in Session Tab

 
Just realize that this "issue" is back in v5 build 0469... Maybe my configuration is wrong?
Monday, January 12, 2015 1:28 AM - Support

Re: Title is not updated in Session Tab

 
Have you done this already?

1. Set the terminal type to xterm
2. Xshell takes what is after the colon (:) characters from the title and uses it as the path of the current working directory. Try adding the following lines in the .bashrc file to add path at the end of the title.

PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/~}"; echo -ne "\007"'


---
Technical Support
Tuesday, January 13, 2015 6:24 AM - Shuai

Re: Title is not updated in Session Tab

 
xterm is used in xshell but you lost me on the 2nd item you listed...
Friday, January 16, 2015 3:25 AM - Support

Re: Title is not updated in Session Tab

 
I am sorry about the confusion. This feature has been added under the Advanced option in the Tools > Options menu.

If you don't like to see the session name after it disconnects, clear the following option:

Show disconnected session name on the session tab

---
Technical Support
Wednesday, January 21, 2015 5:10 AM - Shuai

Re: Title is not updated in Session Tab

 
Thanks, it is working as expected now.