Xshell Forum

Missing charsets in Xemacs

Last post: Monday, February 12, 2007 9:30 PM by Fabrizio Salvatore, 2 reply

 
Saturday, February 10, 2007 2:04 AM - Fabrizio Salvatore

Missing charsets in Xemacs

 
Hi,

I've installed Xshell 2.0. I log-in on a linux box and run Xemacs on it. I have the following warning:

Warning: Missing charsets in String to FontSet conversion

On the Xemacs Window I can see that indeed some characters are a bit funny (on the top bar where all the tabs are located (File, Edit, View, etc...).

Do I need to set something extra in Xshell to get the characters properly shown ?

Thanks,

Fab
Monday, February 12, 2007 11:43 AM - Support

Re: Missing charsets in Xemacs

 
XEmacs expects the "legacy" bitmap fonts, which are not included in many modern Unix/Linux distributions. To solve this problem, please change the LANG value to C by running the command below and run XEmacs.

In bash or ksh: export LANG=C
In csh or tcsh: setenv LANG C

If your problem persists, please provide us the following information:

1. Linux/Unix version
2. XEmacs version
3. Server locale setting

Please let us know if we can be of further assistance.

---
Technical Support
Monday, February 12, 2007 9:30 PM - Fabrizio Salvatore

Re: Re: Missing charsets in Xemacs

 
Hi,

it works, thanks !

Regards,

Fab