Xshell Forum

Serial Communication

Last post: Sunday, April 6, 2014 8:02 PM by Suport, 1 reply

Saturday, April 5, 2014 1:13 AM - Saffi

Serial Communication


I am trying to communicate with my Bluetooth module using a dongle, the dongle and the Bluetooth device is connected, and also when I run a session on Xshell 4 it shows that it is connected. The Bluetooth module accepts AT commands.

Now, the problem that I am facing is when I try and send a command, I don't get a response; and when I try and just receive data I still am unable to do so.

I have tried with a wired RS232 usb and can Receive just fine, (not on Xshell4) but once I transmit with the Bluetooth Module, the same data, I don't get anything.

Any hints/tips?


Program Ver. : Xshell 4
Sunday, April 6, 2014 8:02 PM - Suport

Re: Serial Communication

We haven't tested Xshell with Bluetooth Module. We will need to try this settings if we can. Can you tell your exact settings?

- What kind of device are you trying to connect to?
- What is the name and brand of Bluetooth Module? Website link would be helpful.
- Try connecting to the device via USB-Serial. Does it work?

We can't guarantee you on this fix at this point but will try to configure similar environment if we can.

Technical Support

Facebook: http://facebook.com/netsarang