Xshell Forum

How to turn on URL hyperlink

Last post: Tuesday, February 11, 2014 1:04 AM by Support, 13 reply

 
Saturday, February 1, 2014 11:49 AM - BOB

How to turn on URL hyperlink

 
Hi,

I have read a lot of article about people using hyperlink in Xshell, but I just wonder how to turn it on? I could not find the setting.

when I read something within xshell, I hope it can turn URL http://xx.xxx part into clickable hyperlink so I can mouse click on that to open broswer.

thanks!

Bob



Program Ver. : Xshell 4
Sunday, February 2, 2014 5:05 PM - Support

Re: How to turn on URL hyperlink

 
To enable URL hyperlink, go to Tools > Options > Keyboard and Mouse and then select the Use URL hyperlink option.

---
Technical Support
Sunday, February 2, 2014 11:57 PM - bob

Re: How to turn on URL hyperlink

 
thank you! it is clickable now!

However, two more questions:
1. I click on the link but it doesn't popup in IE or Chrome. I just wonder anything I need to setup to open the link the the broswer?
2. I logout and relogin, I got error message while auto login

---------------------------
Xshell
---------------------------
Encountered an improper argument.
---------------------------
OK
---------------------------


thanks

Monday, February 3, 2014 12:44 AM - Support

Re: How to turn on URL hyperlink

 
1. What is the URL you have clicked?

2. Can you reproduce the issue? If so, please tell us how.


---
Technical Support
Monday, February 3, 2014 2:24 AM - bob

Re: How to turn on URL hyperlink

 
There is an old forum, bbs, using port 23 or 22 to connect to the terminal. a lot of people post their articles there.

after check that URL box, I always get that error message all the time, and I can lick on "OK" one to 5 times to get over that error message.

people post anything inside that forums, so it could be any link, but most of Http:// and nothing can open up my broswer, Chrome. I just wonder where should setup to open Chrome or even IE is fine.

thanks.

Monday, February 3, 2014 1:19 PM - bob

Re: How to turn on URL hyperlink

 
I just test in another machine (win 7) it seems everything is fine. (open chrome, no error pops up)

The problem machine is win 8 pro. I just wonder if it is the problem?

I also found if something before http:// Xshell won't pick up as a hyperlink, I just wonder if there is anyway I can setup in the keyboard setting for making those clickable like | *http:// />
example:
photo link:https://picasaweb.google.com/111816061679764717955/SRnjk#

thanks!

Monday, February 3, 2014 6:24 PM - Support

Re: How to turn on URL hyperlink

 
You can try setting *http:// as the hyperlink prefix in Tools > Options > Keyboard and Mouse tab > URL prefix. We will consider supporting regular expression here.

Hyper link feature should work on Windows 8 as well. I have tested Xshell on Windows 8.1 and the hyperlink works as expected. I don't think this is an operating system specific issue.

Can you give us the following information so that we can try duplicate this issue?

1. Steps to reproduce the issue (you can use Windows PSR tool to record the steps: http://windows.microsoft.com/en-us/windows7/how-do-i-use-problem-steps-recorder)

2. Which font do you use in Xshell?

3. Which encoding do you use in Xshell?



---
Technical Support
Tuesday, February 4, 2014 1:57 AM - Bob

Re: How to turn on URL hyperlink

 
Hi,

thanks a lot for the help!

could you please take a look when you have time. thanks!

The file was too big so I modified it.

Tuesday, February 4, 2014 11:31 PM - Support

Re: How to turn on URL hyperlink

 
Thank you for the update. We have reviewed the steps.

For un-clickable link issue, I don't see there is * in front of the link: http://blog.xunit.... I am not sure why you want to add *http:// as URL prefix. Xshell does not look at the email source. It parses what is actually displayed on the screen.

About the second problem, link not opening in the browser, I think there is a problem with the default browser. Try opening the Windows execute dialog box (Window button + R) and enter http://www.google.com and see if it opens the browser. If this fails, it means there is a problem finding the default browser.



---
Technical Support
Wednesday, February 5, 2014 3:34 PM - Bob Yang

Re: How to turn on URL hyperlink

 
thanks for looking at it..

Do you mean the step 13? There are extra text before the http://. That's the reason, in the step 8, I add "*http://" in the very end to see if I can parse anything with * if anything before "http://".

Regrading to no action after clicking, I tried win+R then https://google.com which has no problem at all in my win 8.1 machine. But Xshell doesn't open anything. I even try using admin account to execute the exe but still the same result. However, I test the same article in a win 7 machine, Xshell open the link automatically.

thanks
Wednesday, February 5, 2014 6:24 PM - Support

Re: How to turn on URL hyperlink

 
Thank you for explaining this.

Wild card characters such as * will not work in URL prefix. You have to specify the exact phrase. Sorry about the confusion.

I think this is a system specific issue. Our team has tested the issue on Windows 8.1 but couldn't duplicate it. We will look into this case more but at this point, we are not sure why this occurs on your Windows 8.1 machine only.



---
Technical Support
Thursday, February 6, 2014 8:17 AM - Bob

Re: How to turn on URL hyperlink

 
thank you!

I also try to use :http:// and hyperlink still not clickable. I guess it won't take unicode char?

thanks a lot for all helps! I will test more to see how to open the browser if there is setting I should setup. I will post here if I can find a solution.

thanks!

Sunday, February 9, 2014 11:10 PM - Bob

Re: How to turn on URL hyperlink

 
Hi here is what I found so far.

1. I don't see the error, when I disable URL hyperlink option.
2. I must use mouse click on "OK" to disable another popup, if I use the keyboard "enter" key, it keeps on popping up the same error message
3. I don't see the error if I disable the auto login.


hope it helps :)

Tuesday, February 11, 2014 1:04 AM - Support

Re: How to turn on URL hyperlink

 
Thank you for the update. I will pass it to our developers.


---
Technical Support