Xshell Forum

[bug]remote ssh “rz” bug

Last post: Thursday, November 28, 2013 9:32 PM by fanglei03, 2 reply

 
Thursday, November 28, 2013 2:03 AM - fanglei03

[bug]remote ssh “rz” bug

 
Step1:connect to a linux server(server1) use xShell
Step2:ssh to another linux server(server2) use (server1) terminal
Step3:transfer a file use command "rz"

And, we will see the bug, like this:
FEc3&阜镇F谣以邪?q
ǜ..?[^(?
?溷WC〔H{._?o???g.γ?P佼?(稗.?N.?z?塍噼???[
> ^XX―.??郊.?..间 ..2.?督バmI?Lプo扁ZU_N筒.?.芋??G拼.?lR5T..??€.圄?臀1??.R第╇..H七. o墒?W??Nr>?v.
> ?v?G.3?.刖蜈’d..s?p椿e醵绰L?.

and then transfer failed.

Program Ver. : Xshell 4
Thursday, November 28, 2013 6:10 PM - Support

Re: [bug]remote ssh “rz” bug

 
When transferring files via zmodem, data stream includes flow control characters. This becomes a problem when you are connecting to the destination server through an intermediary server.

To avoid this issue, try using the -e option when using the rz command like this:

$ rz -e


-e, --escape
Force sender to escape all control characters; normally XON, XOFF, DLE,
CR-@-CR, and Ctrl-X are escaped.


---
Technical Support
Thursday, November 28, 2013 9:32 PM - fanglei03

Re: [bug]remote ssh “rz” bug

 
Thank you!
It works!