Xshell Forum

Build 0128 black text bug

Last post: Monday, January 12, 2015 1:26 AM by Support, 23 reply

Tuesday, November 5, 2013 11:07 PM - Jalen

Build 0128 black text bug

First, thanks for fix 256 color bug that I asked.

I found something wrong in new version. I am not sure this is XShell's problem or not.

This problem happened when using:
2.IRSSI (IRC Client)

In IRSSI, when press up or down, it will show previous command or text that had typed. In 0128 build, it shows with black text that can't see. Text is exists.
When I change text color, font or size, It appears. This situation didn't happen on 0127 version.

Program Ver. : Xshell 4
Wednesday, November 6, 2013 4:02 PM - Support

Re: Build 0128 black text bug

Thank you for reporting the issue.

I have tried running screen and irssi on the latest Xshell build but wasn't able to duplicate the problem. Could you tell us the followings?

1. What is the font you are using and what size?
2. What is your color scheme?
3. Can you add the screenshot of the problem?

Technical Support
Thursday, November 7, 2013 12:37 AM - bc

Re: Build 0128 black text bug

I also have this issue with build 0128.

However, I also get strange results if I just login on the remote host and type 'reset'. This gives a total black terminal with the cursor at the top-left corner. If I clear the terminal with ctrl-l (or typing 'clear'), the prompt appears again.
I tried all available Terminal Type Emulations, but it happens with any of them.

Using the exact same settings in build 0126 works fine. After a clear, the xhell window resizes itself to a width of 80 characters and the terminal prompt is shown.

Update: I was trying to enable/disable terminal features to see if it would make any change, and suddenly the problem is gone. The last change I made was checking all boxes at Terminal/Advanced/Miscellaneous and reconnecting. I get the same behaviour as 0126 and cannot reproduce the problem anymore. Even with the same terminal settings (all boxes unchecked). Strange things :-) As far as I can tell, my problem is now solved (both the irssi and reset issue).

Update2: The problem is back. The scrollback in irssi worked a short time but now it's broke again (during the same session). Also the reset issue is back. Almost seems like some characters are not handled correctly anymore in xshell and cause strange results. However, the ctrl-l trick also works in irssi.

Kind regards,
Thursday, November 7, 2013 6:49 PM - Support

Re: Build 0128 black text bug

There is an option in Xshell that is used make Xshell ignore remote terminal size request. Please check if this option is not selected. It is under the session properties > Terminal > Advanced > Disable terminal size change upon request.

What is the name and version of the UNIX/Linux server?

Technical Support
Friday, November 8, 2013 12:20 AM - bc

Re: Build 0128 black text bug

All options in Terminal/Advanced/Miscellaneous are unchecked.

I have problems connecting to a moderate up-to-date 32bit archlinux installation and to an ancient debian machine. I did not test on other systems.

With other color schemes, the problem persists. But I noticed if the terminal is 'corrupt', changing the color scheme 'fixes' the current display (until it changes again). To me, it appears parts of the terminal are sometimes not redrawn correctly on changes and a complete redraw 'fixes' it.

For now I reverted back to my previous version (build 0126) since build 0128 is rather unworkable for me. Programming in vim also was a problem (lines that disappeared or where not updated correctly).

If there are any specific tests you want me to perform, I can update back to build 0128 if you want.
Friday, November 8, 2013 2:27 PM - Support

Re: Build 0128 black text bug

Thank you for explaining this in detail.

Let me first check with our developers to see if any of the following changes can cause this result:

Xshell 4 Build 0128, Oct 30, 2013
FIX: 2 byte character disappears when placed at the end of the line
FIX: Telnet session crashes when keep-alive option is not configured
FIX: Some 256 color codes are interpreted incorrectly
FIX: Auto-wrap feature does not work properly

If you are using Windows 7 or above, can you use psr.exe (default Windows app) to record the steps and send it to us?

Technical Support
Friday, November 15, 2013 7:33 AM - Jalen

Re: Build 0128 black text bug

Sorry for reply late...

Here are some pictures. I make a zip file.

1.PNG is normal with font name Courier New and size 14.
2.PNG is the situation that I say with black text.
3.PNG is the situation happened and I change text size, it becomes normal.
4.PNG is half black text with dual bytes chinese.
Attachment v128.zip (455.5 KB)  
Thursday, September 4, 2014 9:39 AM - Derrick Peckham

Re: Build 0128 black text bug

I too am experiencing this issue on Windows 7 with screens with Xshell 4 (Build 0131). If I switch from one screen to another then back the text will redraw. It doesnt always happen, but once it starts it never stops. It only happens when i use up/down to scroll through my command buffer or if i hit tab for file completion.
Here are my term entries for bash:

TERMCAP=$'SC|screen|VT 100/ANSI X3.64 virtual terminal:\\\n\t:DO=\\E[%dB:LE=\\E[%dD:RI=\\E[%dC:UP=\\E[%dA:bs:bt=\\E[Z:\\\n\t:cd=\\E[J:ce=\\E[K:cl=\\E[H\\E[J:cm=\\E[%i%d;%dH:ct=\\E[3g:\\\n\t:do=^J:nd=\\E[C:pt:rc=\\E8:rs=\\Ec:sc=\\E7:st=\\EH:up=\\EM:\\\n\t:le=^H:bl=^G:cr=^M:it#8:ho=\\E[H:nw=\\EE:ta=^I:is=\\E)0:\\\n\t:li#56:co#270:am:xn:xv:LP:sr=\\EM:al=\\E[L:AL=\\E[%dL:\\\n\t:cs=\\E[%i%d;%dr:dl=\\E[M:DL=\\E[%dM:dc=\\E[P:DC=\\E[%dP:\\\n\t:im=\\E[4h:ei=\\E[4l:mi:IC=\\E[%d@:ks=\\E[?1h\\E=:\\\n\t:ke=\\E[?1l\\E>:vi=\\E[?25l:ve=\\E[34h\\E[?25h:vs=\\E[34l:\\\n\t:ti=\\E[?1049h:te=\\E[?1049l:us=\\E[4m:ue=\\E[24m:so=\\E[3m:\\\n\t:se=\\E[23m:mb=\\E[5m:md=\\E[1m:mr=\\E[7m:me=\\E[m:ms:\\\n\t:Co#8:pa#64:AF=\\E[3%dm:AB=\\E[4%dm:op=\\E[39;49m:AX:\\\n\t:vb=\\Eg:G0:as=\\E(0:ae=\\E(B:\\\n\t:ac=\\140\\140aaffggjjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~..--++,,hhII00:\\\n\t:po=\\E[5i:pf=\\E[4i:k0=\\E[10~:k1=\\EOP:k2=\\EOQ:k3=\\EOR:\\\n\t:k4=\\EOS:k5=\\E[15~:k6=\\E[17~:k7=\\E[18~:k8=\\E[19~:\\\n\t:k9=\\E[20~:k;=\\E[21~:F1=\\E[23~:F2=\\E[24~:F3=\\E[2P:\\\n\t:F4=\\E[2Q:F5=\\E[2R:F6=\\E[2S:F7=\\E[15;2~:F8=\\E[17;2~:\\\n\t:F9=\\E[18;2~:FA=\\E[19;2~:kb=^H:K2=\\EOE:kB=\\E[Z:\\\n\t:kF=\\E[1;2B:kR=\\E[1;2A:*4=\\E[3;2~:*7=\\E[1;2F:#2=\\E[1;2H:\\\n\t:#3=\\E[2;2~:#4=\\E[1;2D:%c=\\E[6;2~:%e=\\E[5;2~:%i=\\E[1;2C:\\\n\t:kh=\\E[1~:@1=\\E[1~:kH=\\E[4~:@7=\\E[4~:kN=\\E[6~:kP=\\E[5~:\\\n\t:kI=\\E[2~:kD=\\E[3~:ku=\\EOA:kd=\\EOB:kr=\\EOC:kl=\\EOD:km:'
Thursday, October 9, 2014 2:42 AM - Bean

Re: Build 0128 black text bug

Any update on this, please?
I'm too experiencing the same problem when using screen.
Thursday, October 9, 2014 2:43 AM - Bean

Re: Build 0128 black text bug

Forgot to mention, i'm on the latest XShell 4 version 0138.
Thursday, October 9, 2014 9:42 PM - Support

Re: Build 0128 black text bug

Can you use the psr.exe tool to record the steps to reproduce the problem?

Technical Support
Sunday, October 19, 2014 8:18 AM - Bean

Re: Build 0128 black text bug

Hi there, i have created the report with psr.exe, and attached it.
I have tried to comment every step, but again, here are the steps to reproduce the bug:
- open xshell and ssh to a server
- start screen
- open a file with vim. the file should be at least two lines long (eg.: vim .bashrc)
- press these keys in this order, once: PageDown, PageUp, Enter
- try to log out with ":q"
- if everything is goes according plan, then you won't see the colon, only the character 'q'. the colon is rendered with black color (you can check it by selecting this two characters with the mouse, you can see both of them inverted)
- now the terminal colors are already messed up, try it with opening a long directory with mc, go to the bottom with PageDown then try to go up with the Up arrow keys.

Hope it helps to fix this bug soon, it's kinda annoying.
Sunday, October 19, 2014 8:50 PM - Lars

Re: Build 0128 black text bug

I'm having trouble with this as well, making using xshell very bothersome. It's a strange issue that seems to happen at random, but happens often enough to be annoying.

Is there a way to get the 126 version that didn't have this behavior?

Monday, October 20, 2014 10:50 AM - lars

Re: Build 0128 black text bug

Just wanted to put this up here in case others are looking for a solution for this. A work around I found is to use tmux instead of screen, the black text issue doesnt appear to happen under tmux.
Monday, October 20, 2014 7:25 PM - Support

Re: Build 0128 black text bug

We have successfully duplicate the problem! Thank you for all of your input. We will try to fix this ASAP.

Case # for this is 2796

Technical Support
Monday, November 3, 2014 3:06 AM - Bean

Re: Build 0128 black text bug

Hi Support, do you know when will you release this update?
Monday, November 3, 2014 10:36 PM - support

Re: Build 0128 black text bug

Thank you for your patience. Now, it's queued for next development cycle.

Technical Support
Tuesday, November 4, 2014 3:45 AM - Bean

Re: Build 0128 black text bug

Thank you, Support!
Just an update, i can see the same behaviour in the latest XShell 5 beta.
Tuesday, November 18, 2014 8:21 AM - Bean

Re: Build 0128 black text bug

Same problem exist in the shiny new XShell 5 stable version (Build 0446).
Suport, can you reproduce it? Can you fix it?
Wednesday, November 19, 2014 8:02 PM - goodgoodday0

Re: Build 0128 black text bug

Support, can you give us a walkaround solution
Thursday, November 20, 2014 12:38 AM - Support

Re: Build 0128 black text bug

We are working on this right now. Thank you for your patience.

Technical Support
Sunday, December 14, 2014 10:08 AM - Bean

Re: Build 0128 black text bug

It seeems that the last patch fixed this issue. Thank you very much! :)
Friday, January 9, 2015 1:41 AM - georgexsh

Re: Build 0128 black text bug

I am using build 138, but I still have the same "reset" issue that is reported above.
Monday, January 12, 2015 1:26 AM - Support

Re: Build 0128 black text bug

This issue has been fixed in the latest Xshell 5. Please try updating to the latest version.

Technical Support