Xshell Forum

shift+Fn shortcut not work

Last post: Thursday, September 18, 2014 12:21 AM by Support, 8 reply

 
Tuesday, September 10, 2013 6:30 PM - shayne

shift+Fn shortcut not work

 
Hi
I defined some shortcut for emacs(shift+F7 Shift+F8..) but when i used them in xshell, "~" will be output but not shortcut?
This feature is work well in absoultetelnet.

Program Ver. : Xshell 4
Tuesday, September 10, 2013 10:24 PM - Support

Re: shift+Fn shortcut not work

 
Can you send us the keyboard combinations and the values assigned to them?

---
Technical Support
Tuesday, December 31, 2013 12:39 AM - shayne

Re: shift+Fn shortcut not work

 
I don't think this related with configurtion, you could have a try in your envirement, I make a large of test by changing configurtion, but... make no sense.
Monday, January 6, 2014 5:01 PM - Support

Re: shift+Fn shortcut not work

 
We have tried duplicating the issue with Xshell and it does show ~ for some keys such as Shift+function key combination. However, this happens to all terminal emulators. We have tested it with AbolusteTELNET, Putty, gnome-terminal and xterm.

However, the keyboard shortcuts defined in ~/.ecmas worked in XEmacs mode but not text based emacs mode.




---
Technical Support
Monday, January 13, 2014 6:49 PM - shayne

Re: shift+Fn shortcut not work

 
Hi
Thanks for your reply, this function indeed works with ~ for most emulators, but for absolutetelnet, which do work well all the time, do you think the issue related with connect protocol? I used telnet with absolutetelent before, but use ssh with xshell now.
And another question, most of Ctrl+Alt+X combination don't work, I bind some function to Ctrl+Alt+X, such as Ctrl+Alt+A, when push these combination, threre is no reaction.
Monday, January 13, 2014 10:21 PM - Support

Re: shift+Fn shortcut not work

 
Those key combinations are not sent to the remote host. We are working on a way to send all key combination to the remote host. I will be sure to update the request for this feature.


---
Technical Support
Wednesday, September 17, 2014 3:26 AM - JY Li

Re: shift+Fn shortcut not work

 
Seems the issue not addressed in XShell 5 yet.
Any progress?
Wednesday, September 17, 2014 8:46 PM - JY Li

Re: shift+Fn shortcut not work

 
In SecureCRT, Ctrl-V, Shift-Up gives "^[[1;2A", while in Xshell 4/5, nothing happened.
That's sure not right.
Hope the dev team fix this soon.
Thursday, September 18, 2014 12:21 AM - Support

Re: shift+Fn shortcut not work

 
Case # for this issue is 2730. This issue has been queued and we will work on it shortly.


---
Technical Support