Xshell Forum

Authentication mehod and xagent

Last post: Wednesday, August 21, 2013 8:04 PM by Support, 1 reply

 
Wednesday, August 21, 2013 7:31 AM - Aleks LA

Authentication mehod and xagent

 
Dear Netsarang-Team.

I have some servers on which I can only authenticate over username & password.

I have assumed that when I setup in

'Connection > Authenticaton'
Method: Password

xshell and xagent does not try to use the public key authentication method similar like the ssh command.

ssh -v -o PasswordAuthentication=yes -o PreferredAuthentications=password ...

This assumation was wrong.

###
[16:29:53] User authentication initiated...
[16:29:53] Sent user name '<MyUSERNAME>'.
[16:29:53] Server support public key authentication method.
[16:29:53] Trying to find ssh-agent...
[16:29:53] Xagent is running. Connecting to ssh-agent...
[16:29:53] Received 5 identity-blob(s) from ssh-agent.
[16:29:53] Trying next identity blob...
[16:29:53] Server rejected the public blob.
[16:29:53] Trying next identity blob...
[16:29:53] Server rejected the public blob.
[16:29:53] Trying next identity blob...
[16:29:53] Server rejected the public blob.
[16:29:53] Trying next identity blob...
[16:29:53] Server rejected the public blob.
[16:29:53] Trying next identity blob...
[16:29:53] Server rejected the public blob.
[16:29:53] No more keys to try.
[16:29:53] Fall back to normal user authentication steps.
[16:29:53] Sent password.
[16:29:53] Access granted.
###

for this server I have setuped the authentication method password.

Thanks for yor help

Program Ver. : Xshell 4
Wednesday, August 21, 2013 8:04 PM - Support

Re: Authentication mehod and xagent

 
To avoid such situation, please try disabling the Xagent option in the session properties. Xagent only works with public key authentication method. To do this, go to the SSH page in the session properties and then, disable the Use Xagent (SSH agent) for handling passphrase option.

---
Technical Support