Xshell Forum

xshell cannot show special UTF-8 symbo

Last post: Tuesday, April 16, 2013 5:18 PM by Support, 2 reply

 
Monday, April 15, 2013 11:24 PM - Tianyi Wu

xshell cannot show special UTF-8 symbo

 
x shell cannot show some utf-8 symbo,
see the picture


twu5@ug01:~|? env
TERM=xterm
SHELL=/bin/bash
XDG_SESSION_COOKIE=21cd4d9eb77b0e442705b70b00000011-1366092502.126411-1261925066
SSH_CLIENT=70.74.233.207 13128 22
SSH_TTY=/dev/pts/0
USER=twu5
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
MAIL=/var/mail/twu5
PATH=/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
LC_COLLATE=C
PWD=/home/dsk07/ugrad/twu5
LANG=en_US.UTF-8
SHLVL=2
HOME=/home/dsk07/ugrad/twu5
LANGUAGE=en_US.UTF-8
LOGNAME=twu5
SSH_CONNECTION=70.74.233.207 13128 129.128.29.31 22
LESSOPEN=| /usr/bin/lesspipe %s
DISPLAY=localhost:10.0
LESSCLOSE=/usr/bin/lesspipe %s %s
_=/usr/bin/env
OLDPWD=/home/dsk07/ugrad/twu5/.my_config
GREP_OPTIONS=--color=auto
GREP_COLOR=1;32
PAGER=less
LESS=-R
LC_CTYPE=en_US.UTF-8
LSCOLORS=Gxfxcxdxbxegedabagacad
LESS_TERMCAP_mb=
LESS_TERMCAP_md=
LESS_TERMCAP_me=
LESS_TERMCAP_se=
LESS_TERMCAP_so=
LESS_TERMCAP_ue=
LESS_TERMCAP_us=

Program Ver. : Xshell 4
Tuesday, April 16, 2013 5:13 PM

Deleted by poster

Tuesday, April 16, 2013 5:18 PM - Support

Re: xshell cannot show special UTF-8 symbo

 
This problem may occur when the terminal type is not setup properly or font does not include the symbols. Try selecting the same font used in Putty.

Also, make sure that you select the correct encoding type from the Xshell main toolbar. You must select the same encoding type with the remote server. To find out the encoding type on the server, use the following command:

echo $LANG


---
Technical Support