Xshell Forum

XShell 4 100% CPU Issue

Last post: Tuesday, July 3, 2012 7:25 PM by Support, 2 reply

 
Sunday, July 1, 2012 3:53 AM - Shaun

XShell 4 100% CPU Issue

 
After I have opened at least 1 active xshell session, my CPU shoots upto 100% when moving the mouse through the session browser (eg to select another session to open).

Is there a bug fix for this? Does anyone else have this issue?
I've reinstalled xShell but that didn't fix the problem. I also have the latest version of xFtp 4 installed also.

I'm running xShell 4 (Build 0108) on Windows XP.

Thanks
Shaun

Program Ver. : Xshell 4
Sunday, July 1, 2012 4:39 PM - Shaun

Re: XShell 4 100% CPU Issue

 
I failed to mention in my initial post that the problem occurs when RDP'd into my PC when xShell is running (eg using MSTSC).

When logged onto the XP PC locally the problem does not occur.

Also, if RDP'd into the XP machine, the problem does not occur if the current focused session is a "local shell". The problem with navigating the session menu only occurs if the current focused session is an active SSH session and your are RDP'd onto the PC.

Cheers
Shaun
Tuesday, July 3, 2012 7:25 PM - Support

Re: XShell 4 100% CPU Issue

 
The same issue did not occur under Windows XP (via RDP) and Windows 2008 (via RDP) with classic theme enabled in our test. Could you answer the following questions to help us further assist you?

1. You mentioned "my CPU shoots upto 100% when moving the mouse through the session browser (eg to select another session to open)." Does CPU usage go down when you close the menu?

2. Enable XP theme and see if the problem occurs.

3. Open the Sessions dialog box in Xshell and see if the problem occurs.


---
Technical Support