Xshell Forum

Trouble paste from clipboard

Last post: Monday, May 14, 2012 2:00 AM by Support, 13 reply

 
Sunday, April 29, 2012 11:48 PM - Ariel

Trouble paste from clipboard

 
Hi,

I`m having problems paste information from Windows clipboard to Xshell4 when have a vi open in a console. When paste the information, starts to scramble or paste an incomplete sequence, specially when clipboard have many lines.

I have tested the same in puTTY and SecureCRT on the same server console and works fine, paste all clipboard content perfectly.

Thanks for your time,

Ariel.

Program Ver. : Xshell 4
Tuesday, May 1, 2012 12:16 PM - Support

Re: Trouble paste from clipboard

 
Please try the following:

1. Upgrade Xshell to the latest release by selecting Check for Updates in the Help menu.
2. What is the lanugage setting on the server (the result of 'echo $LANG') and in xshell (see under the Encoding icon on the standard tool bar)?

If the problem persists, please provide us with the following information:

1. What is the name and version of the remote host?
2. What is your connection method?
3. Save the file when the problem occurs and send it to us along with the file explaining how it should have been if paste was succesful.

---
Technical Support
Wednesday, May 2, 2012 6:28 AM - Ariel

Re: Trouble paste from clipboard

 
Hi,

In the "About" option of Xshell shows:

Xshell 4 (Build 0106)

Module information:
Xshell.exe: 4.0.00102
nssock2.dll: 4.0.0012
nsssh3.dll: 4.0.0023
nsprofile2.dll: 4.0.0017
nslicense.dll: 4.0.0012
nsutil2.dll: 4.0.0032
nsverchk.exe: 4.0.0001
Xagent.exe: 4.0.0009
Xactivator.exe: 4.0.0012

Encoding icon shows: Default language Unicode (UTF-8)

Info about remote hosts:

OS:HP-UX Release: B.11.11

Output of locale command:

LANG=
LC_CTYPE="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_MESSAGES="C"
LC_ALL=


OS:SunOS Release: 5.8

Output of locale command:

LANG=
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_ALL=

Connection method on both servers: Local Network, via SSH2 through a Socks 5 proxy.

I've attached 2 files, one named ok.txt where pasted the clipboard content successfully using puTTY (a text with 700 lines), and other one named error.txt using Xshell where only 23 lines were pasted with many lines missing between the first and the last lines.

Thanks again for your time.

Ariel.
Wednesday, May 2, 2012 7:45 PM - Support

Re: Trouble paste from clipboard

 
We will try to duplicate the problem.

Meanwhile, please try changing the langauge encoding to Western Eurpoean (ISO) or Western European (Windows) and tell us if the problem persists.

---
Technical Support
Thursday, May 3, 2012 12:18 AM - Ariel

Re: Trouble paste from clipboard

 
Hi,

I've tried using Western Eurpoean (ISO) and Western European (Windows), in both cases they had less missed lines (pasted 52 lines of 700), but the behavior remains the same.

Regards,

Ariel
Thursday, May 3, 2012 12:23 AM - Support

Re: Trouble paste from clipboard

 
Thank you for the update. What is the name and version of the proxy server?


---
Technical Support
Thursday, May 3, 2012 2:23 AM - Ariel

Re: Trouble paste from clipboard

 
Hi,

The proxy server is configured on a Linux host:

Red Hat Enterprise Linux AS release 3 (Taroon Update 2)

Kernel: 2.4.21-15.ELsmp (i686)

Regards,

Ariel
Thursday, May 3, 2012 2:55 AM - Support

Re: Trouble paste from clipboard

 
Please try using the 'stty ixoff' before starting vi. Below is the description of the option:

ixoff (-ixoff) Request that the system send (not send)
START/STOP characters when the input queue is
nearly empty/full.


---
Technical Support
Thursday, May 3, 2012 7:14 AM - Ariel

Re: Trouble paste from clipboard

 
Hi,

The "stty -a" command shows:

On HP-UX:

speed 38400 baud; line = 0;
rows = 51; columns = 179
min = 6; time = 1;
intr = ^C; quit = ^\; erase = ^H; kill = ^U
eof = ^D; eol = ^@; eol2 ; swtch
stop = ^S; start = ^Q; susp ; dsusp
werase ; lnext
-parenb -parodd cs8 -cstopb hupcl cread -clocal -loblk -crts
-ignbrk brkint -ignpar -parmrk -inpck istrip -inlcr -igncr icrnl -iuclc
ixon ixany ixoff -imaxbel -rtsxoff -ctsxon -ienqak
isig icanon -iexten -xcase echo echoe echok -echonl -noflsh
-echoctl -echoprt -echoke -flusho -pendin
opost -olcuc onlcr -ocrnl -onocr -onlret -ofill -ofdel -tostop

On Solaris:

speed 38400 baud;
rows = 51; columns = 179; ypixels = 0; xpixels = 0;
csdata ?
eucw 1:0:0:0, scrw 1:0:0:0
intr = ^c; quit = ^\; erase = ^h; kill = ^u;
eof = ^d; eol = ; eol2 = ; swtch = ;
start = ^q; stop = ^s; susp = ^z; dsusp = ^y;
rprnt = ^r; flush = ^o; werase = ^w; lnext = ^v;
-parenb -parodd cs8 -cstopb -hupcl cread -clocal -loblk -crtscts -crtsxoff -parext
-ignbrk brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl -iuclc
ixon -ixany -ixoff imaxbel
isig icanon -xcase echo echoe echok -echonl -noflsh
-tostop echoctl -echoprt echoke -defecho -flusho -pendin iexten
opost -olcuc onlcr -ocrnl -onocr -onlret -ofill -ofdel tab3

I think the ixoff option is already being used.

Anyway, I´ve tried using stty ixoff and -ixoff before vi and in both cases the error still the same.

Regards,

Ariel
Friday, May 4, 2012 2:20 AM - Support

Re: Trouble paste from clipboard

 
We have prepared a development Xshell file. Please rename the original Xshell.exe from the installed directory and save the attached file in that directory.


---
Technical Support

Monday, May 7, 2012 3:16 AM - Ariel

Re: Trouble paste from clipboard

 
Hi,

First of all, thank you for your efforts.

I've tried the new .exe and the problem remains the same. I've tried change some settings too, such as: terminal emulation (vt100, vt102, linux, xterm), language encoding (unicode, western iso and windows) and combined them. I've also compared with puTTY settings, but with the same configuration of puTTY the problem on Xshell persists.

Thanks again for your time.

Ariel.
Wednesday, May 9, 2012 7:13 PM - Support

Re: Trouble paste from clipboard

 
Thank you for your information. Our developers are on this issue right now but it is quite difficult to fix this issue because the problem does not occur under our system settings.

Could you provide us with a temporary test account on your server so that we can try duplicating this issue?

---
Technical Support
Monday, May 14, 2012 12:06 AM - Ariel

Re: Trouble paste from clipboard

 
Hi,

Thank you for your help and support but I can't give you access to our servers because it's goes against college's security policy.

I'll keep doing tests and compare configuration options with puTTY, I'm shure the problem is about settings, not of Xshell itself.

If I find the solution I'll posting it here.

Thanks again, regards,

Ariel.
Monday, May 14, 2012 2:00 AM - Support

Re: Trouble paste from clipboard

 
Thank you. We will further research on this as well. Please let us know if you have any new information.

---
Technical Support