Xshell Forum

start a new gnu screen session will reset term window size

Last post: Monday, May 5, 2014 10:13 AM by Ed T, 6 reply

 
Tuesday, February 28, 2012 3:34 AM - Kirby Zhou

start a new gnu screen session will reset term window size

 
Version 4.0.104

start a new gnu screen session will reset term window size.
How can I prevent this behavior with XShell?

SecureCrt can siliently ignore the window size changing.



Program Ver. : Xshell 4
Tuesday, February 28, 2012 4:06 PM - Support

Re: start a new gnu screen session will reset term window size

 
The feature request has been sent to our developers.
We will consider this feature for our future release.

---
Technical Support
Wednesday, May 23, 2012 8:32 PM - Kirby Zhou

Re: start a new gnu screen session will reset term window size

 
The changelog seems the bug is fixed, but actually not. The window size will be resetted to 80*35 if I takes 132*35 as the default windows size.

Xshell 4 Build 0106, Apr 02, 2012
MOD: When resetting the Window Size, default window size is used instead of 80x24.
Wednesday, May 23, 2012 10:07 PM - Support

Re: start a new gnu screen session will reset term window size

 
There is a new option in Properties > Terminal > Advanced to disable terminal size change. Select the "Disable terminal size change upon request" option in the session properties > Terminal > Advanced page.


---
Technical Support
Saturday, March 2, 2013 9:27 PM - udayakumar

Re: start a new gnu screen session will reset term window size

 
i am using Xshell 4 (Build 0123)

still i have this issue.... (after change the option Terminal>Advanced>Disable Terminal size upon request)
please test in the lab Technical Support.
Monday, March 4, 2013 1:21 AM - Support

Re: start a new gnu screen session will reset term window size

 
As I have answered in the other thread, could you check the settings under the Terminal page in the session properties?


---
Technical Support
Monday, May 5, 2014 10:13 AM - Ed T

Re: start a new gnu screen session will reset term window size

 
This issue has plagued me for the longest time. I recently started to use Mobaxterm which out of the box didn't have this issue, however Mobaxterm started to have issues with one of my servers SSH keys so rather than waste time trying to figure it out I reverted back to X-Shell.

I currently don't own a business license for X-Shell but would definitely upgrade from the free home/school use version if you guys can fix this and another font issue!

I am using what I believe to be the latest and greatest, Xshell 4 (Build 0131)