Xshell Forum

Xshell taking long time

Last post: Tuesday, January 2, 2018 2:18 AM by Support, 3 reply

 
Tuesday, September 27, 2011 3:42 AM - Amardeep Sidhu

Xshell taking long time

 
Hi Guys,

Facing a strange issue:

While ssh'ing a server (HP Ux Itanium) through putty, it works perfectly ok. But if connecting through XShell (using ssh) it takes 4-5 minutes. Traced user authentication process in XShell and following is the output.

Connecting to x.y.z.w:22...
Connection established.
Escape character is '^@]'.
[15:26:18] Version exchange initiated...
[15:26:18] server: SSH-1.99-OpenSSH_5.3p1+sftpfilecontrol-v1.3-hpn13v5
[15:26:18] client: SSH-2.0-nsssh2_3.0.0019 NetSarang Computer, Inc.
[15:26:18] SSH2 is selected.
[15:26:18] Algorithm negotiation initiated...
[15:26:18] key exchange: diffie-hellman-group14-sha1
[15:26:18] host key: ssh-dss
[15:26:18] outgoing encryption: aes128-cbc
[15:26:18] incoming encryption: aes128-cbc
[15:26:18] outgoing mac: hmac-sha1
[15:26:18] incoming mac: hmac-sha1
[15:26:18] outgoing compression: none
[15:26:18] incoming compression: none
[15:26:18] Host authentication initiated...
[15:26:18] Hostkey fingerprint:
[15:26:18] ssh-dsa 1024 a1:02:6e:f1:8c:de:cc:e1:e6:09:f0:27:82:a1:24:4e
[15:26:18] Accepted. Verifying host key...
[15:26:18] Verified.
[15:26:18] User authentication initiated...
[15:26:18] Sent user name 'oracle'.
[15:26:18] Sent password.
[15:31:05] Access granted.

Last successful login: Wed Sep 28 01:44:35 IST 2011 10.108.26.30
Last authentication failure: Tue Sep 6 04:44:51 IST 2011 10.108.26.30
Last login: Wed Sep 28 01:41:02 2011 from 10.130.250.159
.
.
.


$

In Putty it takes only a few seconds.

Any clues what could be wrong ?

Thanks
Sidhu

Program Ver. : Xshell 3.0
Thursday, September 29, 2011 12:56 AM - Support

Re: Xshell taking long time

 
Please try the following:

After the following message while Xshell is waiting, click on the reconnect icon from the Standard toolbar.

'Last login: Wed Sep 28 01:41:02 2011 from 10.130.250.159'

Also, please send us the following information:

1. Xshell build number (Help > About)
2. Does the same problem occur on any other machine?

---
Technical Support


Wednesday, December 27, 2017 3:43 PM - CESAR

Re: Xshell taking long time

 
I'm having the same problem on 2017! It takes almost 1 minute.
Disconnect-Reconnect also takes forever.

Putty connects in 1 second.
Tuesday, January 2, 2018 2:18 AM - Support

Re: Xshell taking long time

 
Can you provide more details on your issue? Context would be very helpful. Screenshots would be appreciated as well.

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog