Xshell Forum

Want terminal to be focused first and incorrect interpretation of ' and ".

Last post: Monday, February 6, 2006 12:01 PM by Support, 1 reply

 
Sunday, February 5, 2006 6:46 AM - Otem

Want terminal to be focused first and incorrect interpretation of ' and ".

 
I have two problems.

First, I would like the text terminal get focus first when I entering the Xshell window. Is there a way to change the "Tab" order of all the subwindows?

The terminal does not seems interpret the character ' and " correctly (see attachement). How to fix this problem?

Thanks
Attachment Snap1.gif (29.8 KB)  
Monday, February 6, 2006 12:01 PM - Support

Re: Want terminal to be focused first and incorrect interpretation of ' and ".

 
This problem may occur when the Xshell encoding and server locale do not match. To fix this problem, first, check locale of your server with the following command:

[Zheng@192.168.1.9] echo $LANG

And then, set Xshell locale accordingly. To do this, please follow the instruction below:

1. Open Xshell.
2. From the Xshell menu, click File, and then Open.
RESULT: Sessions dialog box opens up.
3. Right click on the session that you are experiencing problem with, and then click Properties.
RESULT: Session Properties dialog box opens up.
4. Click the Advanced tab.
5. In Output translation, select an encoding type accordingly.
6. Click OK to save the change.

For Xshell focus problem, we could not duplicate your problem. Please tell us in detail how we can duplicate this problem.

If your problem persists, please include the following information in your next posting.

1. Name and version of your server
2. Server locale setting (Result of 'echo $LANG'

Please let us know if we can be of further assistance.

---
Technical Support