Xshell Forum

colored terminal causes missing underscores

Last post: Monday, July 11, 2011 10:05 PM by Support, 6 reply

 
Tuesday, April 19, 2011 1:42 PM - Jeff

colored terminal causes missing underscores

 
I've installed on my new laptop and now underscores do not appear in my terminal. Un-colored text appears fine.

This happens regardless of the application I'm using (e.g. vim, emacs, etc.), on both 3.0 and 4.0 beta.

I've attached an example of how it looks using a simple directory listing (e.g. ls --color). All three files/directories have underscores in them, not spaces.

Thoughts?





Program Ver. : Xshell 3.0
Thursday, April 28, 2011 12:13 AM - Support

Re: colored terminal causes missing underscores

 
Thank you for reporting the problem. I have reported the problem.

---
Technical Support
Tuesday, May 3, 2011 6:36 PM - Support

Re: colored terminal causes missing underscores

 
We could not duplicate this problem. Could you tell us the following information?

1. Desktop screen resolution
2. Try selecting a different font (i.e. courier)
3. Attach the color scheme. Go to Tools > Color Schemes and then select Export.

---
Technical Support
Wednesday, May 4, 2011 6:20 PM - Jeff

Re: colored terminal causes missing underscores

 
1600x900 is my resolution. I've tried others, with no change.

Switching to any font but Courier New seems to work!

Color scheme attached.
Wednesday, May 4, 2011 8:38 PM - Support

Re: colored terminal causes missing underscores

 
We tried to duplicate the problem with the provided color scheme with different font settings. But, the problem did not occur.

This might be caused by Windows cleartype settings but we can't be sure at this moment. We will do some more research and get back to this post as we find out more.

Thank you for your patience.

Please feel free to share any information that may help us resolve this problem.


---
Technical Support
Monday, July 11, 2011 3:23 PM - roderick

Re: colored terminal causes missing underscores

 
I have the same problem,
try courier new with 9 in size.
all underscore becomes space
Monday, July 11, 2011 10:05 PM - Support

Re: colored terminal causes missing underscores

 
We have noticed the underscore disappearing when the line spacing is set lower to -1 or lower. But, it looks like the problem occurs in other conditions as well.

Please try the following solutions:

1. Try increasing the line spacing in session properties (Appearance > Margins > Line Spacing)
2. Try using a different font such as Consolas.

---
Technical Support