Xshell Forum

Xshell disconnection on unused SSH to a Cisco 7609

Last post: Thursday, April 28, 2011 11:00 AM by Piracanto, 3 reply

 
Friday, April 1, 2011 12:34 PM - Piracanto

Xshell disconnection on unused SSH to a Cisco 7609

 
I can't keep a ssh connection to a Cisco 7609 box.

The Cisco doesn't have a timeout for any connection.

I already tried the "Send Keepalive messages while this session is connected" option, its set in 45 seconds, but every time it disconnects after around 5 minutes.

Only workaround so far is typing something in the ssh tab/window so the session stays connected.

Program Ver. : Xshell 4 Beta
Monday, April 4, 2011 7:49 AM - Support

Re: Xshell disconnection on unused SSH to a Cisco 7609

 
Some SSH servers ignore the KeepAlive messages by design. This might be the case of CISCO 7206. We will investigate this problem further by using an emulator software to find out if it can be fixed from our end.

Meanwhile, could you send us the following information?

Connection trace log. (Enable the "SSH Version, algorithm exchange and user authentication" and "SSH TCP/IP and X11 tunneling" options in the Trace page of the Session properties.)

Thank you for your cooperation.

---
Technical Support
Monday, April 4, 2011 3:36 PM - Piracanto

Re: Xshell disconnection on unused SSH to a Cisco 7609

 
Thanks a lot, this is what I get after a connection and disconnection:


[BEGIN] 4/4/2011 6:10:41 PM


User Access Verification

Username: yyy.yyy
Password:
COMPANY-C7609-1#
COMPANY-C7609-1#show interfaces s9
% Incomplete command.

COMPANY-C7609-1#
Connection closed by foreign host.

[END] 4/4/2011 6:20:55 PM
Thursday, April 28, 2011 11:00 AM - Piracanto

Re: Xshell disconnection on unused SSH to a Cisco 7609

 
Any replies?