Xshell Forum

URL hyperlinking problem

Last post: Friday, March 18, 2011 12:29 PM by strawman, 5 reply

Monday, March 14, 2011 4:21 AM - strawman

URL hyperlinking problem

something strange is happening to URLs in xshell; basically, whenever i click a URL, xshell will either remove the final character or insert a load of random characters. for example, whenever i login to my server i get a link to https://help.ubuntu.com/ - when i click it, it either becomes something like the following:

...or just https://help.ubuntu.co/ which obviously isn't much more use.

i've changed literally every setting i can think of, reinstalled several times, deleted my settings folder, installed inside a VM, connected to four different remote machines running different linux/BSD distros, even tried a different browser, and still no luck. the weirdest thing is that hyperlinking used to work perfectly; it broke all of a sudden without me even changing any settings (as far as i know) and has been totally broken ever since.

please help, i really don't want to have to use PuTTy :(

Program Ver. : Xshell 3.0
Monday, March 14, 2011 4:12 PM - mlm

Re: URL hyperlinking problem

I use Xshell 3.0 on Win XP, and Xshell 4 beta on Win7.
On Win7 everything is ok, but on Win XP with Xshell 3 I've got the same situation.

Sometimes URL is open without last char, or with many different chars.

The most interesting is that earlier it works good, probably something was changed in one build.
Tuesday, March 15, 2011 2:55 AM - Support

Re: URL hyperlinking problem

We have tested URL hyperlink feature on XP with Xshell 3.0 build 0286 but could not duplicate the problem. What is your Xshell build number (Help > About box)?

Please provide the following information:

1. Does this problem occur every time you enter URL?
2. What do you have for the 'Use URL hyperlinking' option under the Tools > Options > Advanced tab.
3. Which internet browser do you use?

Technical Support

Wednesday, March 16, 2011 1:07 PM - mlm

Re: URL hyperlinking problem

I use the latest version - Xshell 3.0 (Builid 0286).

1. Yes, always.
2. Now I've only "http://", but with default string it behaves the same.
3. Chrome, Firefox - no difference.
Friday, March 18, 2011 11:33 AM - strawman

Re: URL hyperlinking problem

xshell 3.0 0286, windows 7 x64, and tested with firefox 3, chromium and chrome. the problem occurs within ssh connections as well as at the xshell prompt, and with URLs that are printed as well as URLs i type in myself.

Use Hyperlinking is currently set to "http:// | https://", i've tried it with the default setting, the default setting + "https://", as well as just "http://" and the same problem happens every time.

thanks for the reply, i'll do a fresh install of winXP inside a VM later and see if i can reproduce the problem there.

edit: should probably mention that the problem does not occur in xshell 4 beta.
Friday, March 18, 2011 12:29 PM - strawman

Re: URL hyperlinking problem

fresh install of XP SP3, firefox and xshell inside virtualbox; no settings changed except enabling hyperlinking in xshell. as you can see from the attached image, it has the same problem straight out of the box.