Xshell Forum

enable 256color in vim?

Last post: Monday, June 6, 2011 12:39 AM by blah, 5 reply

 
Thursday, March 10, 2011 8:01 PM - rexliao

enable 256color in vim?

 
I try to enable 256color support in vim.I mean that, I want to use a colorful shema in vim, like wombat, evening ect.

Even though i set the TERM to 'xterm-256color' in bash, and 'set t_Co=256' in vim, the wombat colorshema just don't work as expect. looks like it's still in 8color mode.

Please help.

Program Ver. : Xshell 4 Beta
Tuesday, March 15, 2011 2:19 AM - Support

Re: enable 256color in vim?

 
Using 256 colors in VIM requires special settings. Check out the following page:

http://vim.wikia.com/wiki/256_colors_in_vim


Sunday, April 3, 2011 7:15 PM - JQ

Re: enable 256color in vim?

 
I have the same issue.
With other ssh clients, such as putty, it could show all colors.
However, Xshell cannot display 256 colors.
Sunday, May 22, 2011 1:16 AM - yarly

Re: enable 256color in vim?

 
I have this problem too. It's not a terminal problem, it's an "xshell not supporting 256 colors" problem :(

I could post a screen shot to prove my point if needed.
Tuesday, May 24, 2011 1:36 AM - Support

Re: enable 256color in vim?

 
Xshell does support 256 colors. I have attached the screenshot. You need to configure VIM or VI to support 256 colors as I have explained above.


---
Technical Support
Monday, June 6, 2011 12:39 AM - blah

Re: enable 256color in vim?

 
Tried it again, works for me since I switched to xshell4 :)