Xshell Forum

Xshell 2.0: Failed to execute Xmanager

Last post: Monday, November 8, 2010 1:14 AM by Zoo, 4 reply

 
Wednesday, December 28, 2005 10:27 PM - BF

Xshell 2.0: Failed to execute Xmanager

 
28 December 2005

Dear Madam/Sir,

I have recently installed Xshell 2.0 on my laptop (which runs Windows OS) for trial. On opening a
file (on UNIX) with vi editor, the system/program prompts the following error message:

Xshell 2.0
! Failed to execute Xmanager:
Make sure that Xmanager is correctly installed
on the system.

On suppressing the box in which this message appears, the vi editor (on UNIX) opens and one can edit without any further problem, or indication of any possible problem. It seems to me, therefore, that this error message should be bogus and prompted for no good reason at all. (Interestingly, Xmanager seems to be the name of another software product by NetSarang which is distinct from Xshell. Why should Xshell fail to execute Xmanager?)

I should be grateful if you would kindly inform me about the cause of the above-mentioned problem and the way in which it can possibly be resolved.

I thank you in advance for the trouble.

Wednesday, December 28, 2005 11:32 PM - Throw your hands up

Re: Xshell 2.0: Failed to execute Xmanager

 
This problem occurs when VIM is trying to run as an X application with a full GUI interface and mouse support. You can suppress it by using 'vi -X' or 'vim -X' option.

If this doesn't work, check out your vi manual to see which option turns off the X application mode.



Thursday, December 29, 2005 12:03 AM - BF

Xshell 2.0: Failed to execute Xmanager

 

Thank you very much for your prompt response.

Your suggestion, to use < vi -X >, works perfectly.

Thank you again for the trouble.
Saturday, November 6, 2010 2:30 PM - Throw it out

Re: Xshell 2.0: Failed to execute Xmanager

 
vim -X works perfectly, but can we suppress this error message? Just that I am too used to vim instead of vim -X. Thanks.
Monday, November 8, 2010 1:14 AM - Zoo

Re: Xshell 2.0: Failed to execute Xmanager

 
There are several ways.
First, how about using alias like this.
$ alias vi='vi -X'

Second, unset your DISPLAY environment like this.
$ unset DISPLAY

Last, you can disable X11 forwarding(SSH) option and XDISPLOC option(TELNET) in your session profile.