Xshell Forum

4-Beta, XP and Always-on-Top

Last post: Thursday, January 16, 2014 9:36 PM by Support, 4 reply

 
Wednesday, January 19, 2011 6:56 AM - Richard

4-Beta, XP and Always-on-Top

 
Since upgrading to the xshell 4 beta, all my xshell windows are always-on-top, and I can't make them stop it. It's incredibly annoying.

Under Tools/Options there is a "transparency" section, with an Opacity slider that runs from 10% to 90%, and two checkboxes under that for make-opaque-on-mouseover and always-on-top-when-transparent. There's no setting for "never do transparency", but since I'm not seeing transparency anyway I guess that doesn't matter much. And checking/clearing these boxes has no impact on the always-on-top issue.

How can I get xshell to stop monopolizing my display like this?

Program Ver. : Xshell 4 Beta
Wednesday, January 19, 2011 6:05 PM - Support

Re: 4-Beta, XP and Always-on-Top

 
First, make sure the Transparent option is disabled under the View option. Then, disable the following two options:

Make window opaque on mouse over
Always on top when transparent

Also, if the problem persists, please try resetting the registry key. To remove Xshell registry keys:

1. Click on the Windows Start menu and click Run.
2. Enter regedit and press enter.
3. Delete the following registry node:

\HKEY_CURRENT_USER\Software\NetSarang\Xshell



---
Technical Support
Monday, August 29, 2011 11:50 PM - Johnny

Re: 4-Beta, XP and Always-on-Top

 
the key responsible for this is: TopMost in the xshell reg folder. set it to 0 and everything will be ok.
Thursday, January 16, 2014 3:19 AM - Neels

Re: 4-Beta, XP and Always-on-Top

 
To disable always-on-top in Xshell4 I have tried removing \HKEY_CURRENT_USER\Software\NetSarang\Xshell and setting TopMost to 0, but there is always one or more windows that stay on top. What else can I try?

thanks
Thursday, January 16, 2014 9:36 PM - Support

Re: 4-Beta, XP and Always-on-Top

 
Have you tried upgrading to the latest build by selecting the Check for updates in the Help menu?

Always on top uses Alt+A combination. Sometimes this key combination is used for in terminal and cause this problem. Please make sure you are not pressing the Alt+A combination.

Also, if the problem persists, please tell us the followings:

Assuming that the Always on top option is disabled in the View menu;

1. When the problem occurs, see under the View menu to make sure the Always on Top menu is disabled.

2. When this problem happens, can you press Alt+A to disable the Always on top feature?


---
Technical Support