Xshell Forum

Can't set Terminal font in XShell 3 and 4

Last post: Thursday, November 18, 2010 11:44 AM by Varda, 4 reply

 
Monday, November 15, 2010 7:46 AM - Varda

Can't set Terminal font in XShell 3 and 4

 
Hello Gentlemen.

I can't choose/select/set Terminal font for text in console window. I see it and can select from File -> Properties (Alt+P) -> Appearence tab -> Font Name drop down list & Font Size list 14. But it did't set after clicking on OK button of this dialog. Instead it sets to Courier or Lucida Console. Also Terminal font not visible to choose from Fonts toolbar. I've tried both versions 3 latest and 4 beta downloaded today.

Surely Terminal font exists on my Windwos XP SP3 because I set this font for Command Prompt window.

Thank You.

Program Ver. : Xshell 3.0
Tuesday, November 16, 2010 12:08 AM - Support

Re: Can't set Terminal font in XShell 3 and 4

 
To help us better understand the problem, please send us the following information:

1. What is the language setting on Windows?
2. What is the language setting on the remote server?
3. Is there the Fixedsys font when connection is not established?


---
Technical Support
Tuesday, November 16, 2010 1:57 AM - Varda

Re: Can't set Terminal font in XShell 3 and 4

 
Thanks for Your reply.


1. What is the language setting on Windows?

English

2. What is the language setting on the remote server?

Connection is not established. There is initial Local Shell mode.

3. Is there the Fixedsys font when connection is not established?

Yes it present and selecable always.

Please see attached files. First screenshot demonstrate initial state of Local Shell and Fixedsys font. Second screenshot demonstate Terminal font in Properties dialog and following state of main window switched by itself to Courier after applying settings.

Thank You
Tuesday, November 16, 2010 11:36 PM - Support

Re: Can't set Terminal font in XShell 3 and 4

 
Please try changing the encoding on Xshell. To change the encoding:

1. Click on the Encoding button. It is the Globe icon on the left side of the Font icon.
2. Select default language or Unicode.

Check the font list for Fixedsys font.


---
Technical Support
Thursday, November 18, 2010 11:44 AM - Varda

Re: Can't set Terminal font in XShell 3 and 4

 
Yes, it helps.

There was UTF-8 encoding and as you advised I've changed it fo "Default Language" then Terminal font appeared in the list of fonts.

Thank you very much.