Xshell Forum

engineer

Last post: Thursday, September 23, 2010 1:03 AM by Support, 6 reply

 
Wednesday, September 15, 2010 1:42 AM - ynn

engineer

 
using emacs non-gui to write cvs commit message, backspace doesn't work.
Also the shortcut key defined for emacs will not be available if it is taken by xshell.

No problem with putty.

Program Ver. : Xshell 4 Beta
Friday, September 17, 2010 2:55 AM - eng

Re: engineer

 
anyone taking care on the forum?
Friday, September 17, 2010 2:55 AM - eng

Re: engineer

 
anyway, I am back to putty.
Friday, September 17, 2010 3:16 AM - Support

Re: engineer

 
This forum is run by us and other Xshell users.

Emacs should work fine on Xshell. If not, you can try a few options on Xshell. But, before we give a general solution, could you answer the following question to help us better understand your problem?

1. What is the result of 'echo $TERM'?
2. What are the shortcut keys you use on emacs?



---
Technical Support
Tuesday, September 21, 2010 1:19 AM - ynn

Re: engineer

 
both putty and xshell show "XTERM"
Just noticed that putty has the same issue. but with xshell even the backspace doesn't work
as expected.
end key doesn't work in both shell
Shortcut like ctrl-f5 was captured by xshell instead of going to emacs.
I am using emacs -nw
Tuesday, September 21, 2010 2:31 AM - ynn

Re: engineer

 
ok. I map the backspace key to control-? as in putty now it works.
But putty also has the option to configure the home/end key while xshell doesn't.
End key in xshell is broken.
Thursday, September 23, 2010 1:03 AM - Support

Re: engineer

 
Thank you for reporting the problem. We will look in to this new feature/problem.

---
Technical Support