Xshell Forum

Connecting to Mac OS X won't use saved password

Last post: Tuesday, June 8, 2010 8:38 AM by Anville, 2 reply

 
Sunday, May 16, 2010 2:52 PM - Anville

Connecting to Mac OS X won't use saved password

 
I have two Mac mini machines running OS X 10.6.3. Whenever I try to connect to them using Xshell, I can only do it using "keyboard interactive" to send the password. Xshell will never use the password I saved for the session. I don't have this problem with any Linux computers I connect to.

Does anyone else have this problem, and how can I fix it?

Thanks!

Program Ver. : Xshell 3.0
Tuesday, May 25, 2010 1:33 AM - Stehpen

Re: Connecting to Mac OS X won't use saved password

 
It's because the SSH server on the Mac is only allowing keyboard interactive method. You have to enable the password authentication method on the server by setting the PasswordAuthentication value to yes in sshd_config.


Tuesday, June 8, 2010 8:38 AM - Anville

Re: Connecting to Mac OS X won't use saved password

 
That did the trick. I guess they changed the default settings somewhere along the line.

Thanks!