Xshell Forum

XShell Doesn't Recognize Password Auth on Some Configurations

Last post: Friday, October 25, 2013 11:51 AM by Support, 20 reply

 
Tuesday, September 22, 2009 9:36 AM - Gelob

XShell Doesn't Recognize Password Auth on Some Configurations

 
Some Linux distributions (Gentoo, FreeBSD) by default come with PasswordAuthentication Yes commented out in sshd_config by default. This of course makes sshd default to PasswordAuthentication, but because it is commented out when you try to SSH with XShell it only gives you a ssh key prompt. Other ssh clients are able to ssh without issue.

Program Ver. : Xshell 3.0
Wednesday, September 23, 2009 2:10 AM - Support

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
Xshell is smart to know which authentication methods are supported on the remote server and only enables the ones supported by the server. For instance, if the SSH server supports Password authentication method, password field will be enabled automatically.

In other words, the password field will be enabled as long as the server support password authentication even though it is commented out from the server configuration file.

Are you having trouble logging in?

---
Technical Support
Wednesday, September 23, 2009 6:43 AM - Gelob

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
XShell is not interpreting password authentication correctly although the server supports it when it is not specifically specified in the configuration (ex commented out making it the default authentication). This may have to do with how sshd reports to XShell but I believe it is an XShell issue.
Wednesday, September 23, 2009 10:51 PM - Support

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
The problem did not occur under our settings. Please see below for the settins:

Server: Gentoo 6.05
SSH Server: OpenSSH 4.2 (the default SSH server included in Gentoo 6.05)
Client: Xshell 3.0 build 0260

We have set the PasswordAuthentication value to yes and commented the line out. After doing this, we restarted the SSH server to make sure the settings take effect. Then, we used Xshell to connect to the server and noticed the focus was on the Password field in SSH User Authentication dialog box. So, there was no problem entering the password.

Could you tell us the following information to help us find the cause?

1. Version of the server.
2. Screenshot of the problem.
3. How did you start the connection?

---
Technical Support
Thursday, October 29, 2009 12:48 PM - Gelob

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
What seems to be happening is when the SSH server requires keyboard interactive Xshell does not default to it instead you have to select keyboard interactive and then click ok to get the password prompt.
Monday, November 2, 2009 7:06 PM - Support

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
We successfully duplicated the problem. We will fix this problem in the next release. Thank you for reporting the problem.

---
Technical Support
Sunday, December 26, 2010 3:19 PM - Marius

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
Same problem on xshell ver 4.0 ...
Wednesday, January 5, 2011 7:30 AM - Dirk

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
The same problem is with the xshell v4 beta 0074, we use only Gentoo and it is annoying for us to always copy paste the password. Can somebody from technical support tell us if this problem will be fixed?

Thank you!
Tuesday, January 11, 2011 12:07 AM - Support

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
Keyboard interactive is an interactive login method. Oftentimes it requires an answer different from the password. This is why we don't provide an option to enter the answer for keyboard interactive authentication method.

If you want bypass keyboard input, try setting the authentication method (Session Properties > Authentication) to Password and enter in the password.

---
Technical Support



Tuesday, February 1, 2011 11:48 AM - Dirk

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
As others said before me on this topic the problem is that xshell is not interpreting password authentication correctly. When i`m opening a session it defaults on ssh key prompt instead to log in automatically. It had this problem so far only on Gentoo.
Wednesday, February 2, 2011 11:41 AM - lazydba

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
I am having exactly the same issue with some servers.
Sunday, February 6, 2011 5:51 AM - sirius

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
The same on FreeBSD
Saturday, May 21, 2011 9:11 AM - Mark

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
I`ve installed the latest xShell version and still this annoying bug exists...
Wednesday, May 25, 2011 6:22 AM - LazyDBA

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
Will this be fixed in the next release ?

Thanks
Wednesday, May 25, 2011 10:06 PM - Support

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
- PasswordAuthentication is not allowed by default on Gentoo and FreeBSD.
- Public key and keyboard interactive authentication methods are enabled by default on Gentoo and FreeBSD.
- Password authentication and keyboard interactive are not the same.
- So, saving password on Xshell would have no effect.
- The whole point of the keyboard interactive authentication is to be interactive during log on for better security. This is why the password field is disabled for Keyboard interactive.
- The SSH User Authentication dialog box opens up because the connecting SSH server supports more than one authentication methods.

To resolve this issue:
1. Select Keyboard interactive for authentication method on Xshell session properties. This will open password dialog box during login. So, you don't have to choose between public key authentication and keyboard interactive.
2. Disable public key authentication on SSHD and restart SSHD. To disable public key authentication, open /etc/ssh/sshd_config and find the line, '#PubkeyAuthentication yes' and remove the # and change yes to no. Save the change and restart SSHD (/etc/rc.d/sshd restart).

I think everyone on this post agrees that not being able to save password for keyboard interactive is a bit annoying. We can fix this by adding a feature to save password for keyboard interactive. I have already made a request for this feature.


---
Technical Support
Wednesday, August 31, 2011 2:49 AM - LazyDBA

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
Thanks so much. Any progress on this request
Thursday, September 1, 2011 1:07 AM - Support

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
It's in the queue but not yet implemented. I will update this post when the feature becomes available.

---
Technical Support
Wednesday, May 9, 2012 3:35 PM - rocky

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
Any update on implementing this feature?
Wednesday, May 9, 2012 6:40 PM - Support

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
Our developers are working on this feature and it will be available in our next release.

Thank you for being patient.

---
Technical Support
Friday, October 25, 2013 11:27 AM - Mike D

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
Any Update on this issue?
Friday, October 25, 2013 11:51 AM - Support

Re: XShell Doesn't Recognize Password Auth on Some Configurations

 
This feature has been added to Xshell. Please update your Xshell by selecting the Check for Updates in the Help menu.


---
Technical Support