Xshell Forum

Pasting Error

Last post: Wednesday, October 28, 2009 1:05 AM by Support, 19 reply

 
Wednesday, June 10, 2009 7:51 AM - Pravat

Pasting Error

 
I use Vista and am logged on to a HP-UX 11.31 node.

When I try to copy some test (script code) and paste it in Xshell window it misses out couple of line from the output.

e.g.
I tried copying a 250 line script and pasted in vi and saved the file and the line count varies, sometimes it pastes 210lines, sometimes 220lines.
I tired upgrading to the latest release but still no help?

Am pretty much sure, this is something/bug with Xshell, as the same copy-paste operation works smooth with putty.


Program Ver. : Xshell 3.0

=========================================
1. Copied data
Attached

2. Type of shell (bash, ksh, csh)
sh and ksh

3. Terminal type (result of 'echo $TERM')
vt100

4. Vi version
Not sure (on HP-UX V3)
=========================================
Attachment testing.sh (12.6 KB)  
Thursday, June 11, 2009 5:03 PM - Support

Re: Pasting Error

 
We have tried duplicating the problem on HP-UX and Centos but it did not occur on our machines.

Here is what we have tried:
1. Logged in to HP-UX/Centos via SSH
2. Started Vi editor
3. Changed to insert mode by pressing 'i'
4. On Windows, copied the content from testing.sh (all 300 lines) by pressing ctrl+c
5. On Xshell, pasted the contents by pressing Ctrl+insert.
6. Checked the copied contents by looking at the number of lines pasted (I used ':set number' command to show line numbers).

Please let us know if we are missing anything. Also, it would help us resolve this problem, if you can tell us how we can duplicate this.

---
Technical Support

Thursday, June 11, 2009 9:08 PM - Pravat

Re: Pasting Error

 
Yes, this doesn't happen with all the nodes, but time and again I have faced this on many nodes. Now that I can see others also facing similar issue am pretty much sure, this has something to do the Xshell with some specific configuration on the node.

Let me know what if you need any more environmental details of the node, I will be more than happy to provide all those...
Friday, June 12, 2009 2:26 AM - Pravat

Re: Pasting Error

 
Check the attached screenshots...
Sunday, June 14, 2009 11:26 PM - Pravat

Re: Pasting Error

 
What's the update on this?
Monday, June 15, 2009 6:05 PM - Support

Re: Pasting Error

 
The problem could not be duplicated.

Could you the send us the file after pasting fails so that we can see where the pasting when wrong? Since we have the original copied text, we should be able to see which lines are missing.

Also, it would help us duplicating the prboelm if you can provide us with a temporary account to your HP server. Would this be an option?

---
Technical Support
Tuesday, June 16, 2009 12:21 AM - Pravat

Re: Pasting Error

 
Please find attached the file after pasting. The original file has 300 lines and this one has 256 lines.

And as far as the access to HP server is concerned, that's not a option. But let me know, whatever details, command outputs etc you wana know and i will be more than happy to provide you the same.
Tuesday, June 16, 2009 3:48 PM - Support

Re: Pasting Error

 
We have successfully duplicated the problem! Fix is on the way. I will let you know once it becomes available.

---
Technical Support
Tuesday, June 16, 2009 11:11 PM - Pravat

Re: Pasting Error

 
Hummm...

What's the update on this?
Tuesday, June 30, 2009 11:56 PM - Pravat

Re: Pasting Error

 
?
Thursday, July 2, 2009 4:36 AM - Pravat

Re: Pasting Error

 
?
Monday, July 6, 2009 2:01 AM - Support

Re: Pasting Error

 
This fix is queued on our schedule. It seems the problem is caused by flow control issue. However, this is not a small project and will take some time.

We will send you an update when we release the fix.

Thank you for your patience.


---
Technical Support

Monday, July 6, 2009 2:12 AM - Pravat

Re: Pasting Error

 
Appreciate the update...
Monday, August 31, 2009 12:45 AM - Pravat

Re: Pasting Error

 
?
Monday, August 31, 2009 1:00 AM - Support

Re: Pasting Error

 
The problem occurs on slow UNIX machines when using TELNET protocol. SSH does not have this problem. It seems the problem occurs under all terminal emulators.

And again, this feature will not be included in the current version but perhaps will be included in the future. Meanwhile, please try using SSH instead.

---
Technical Support
Tuesday, September 1, 2009 1:59 AM - Pravat

Re: Pasting Error

 
Slow UNIX machines? I don't think, one get anything faster than HP 9000 Superdomes or IBM p5 595. These are few of the VPARs and LPARs where we are having issues and am sure this is nothing to do with the speed and of course we don't use un-secure means of communication like telnet, ssh is by default.
Tuesday, September 1, 2009 2:32 AM - Support

Re: Pasting Error

 
This problem has never been reported before and we could not duplicate it. Could you provide us with a temporary account to your server so that we can try to duplicate the problem from here?

As always, we appreciate your time and feedback.

---
Technical Support
Thursday, September 3, 2009 11:28 AM - Pravat

Re: Pasting Error

 
Providing access isn't a possibility. Let me know what config/env information and command outputs you need and will provide you the same.


As always, happy to help.
Tuesday, October 20, 2009 8:17 AM - Pravat

Re: Pasting Error

 
Any updates?
Wednesday, October 28, 2009 1:05 AM - Support

Re: Pasting Error

 
Mr. Pravat,

We are working on the problem. But, it is going to take awhile until we can release it.

We appreciate your patience.

I will keep you posted via email.

Meanwhile, could you tell us the result of the following test?

1. Open Xshell and vi.
2. Change vi to insert mode.
3. Instead of copying the text, transfer a text file by clicking File > Transfer > Send ASCII.

Does the problem still persist?

Thank you.



---
Technical Support