Xmanager Forum

RH 6.0 with GNOME

Last post: Sunday, February 17, 2002 12:30 AM by Support, 4 reply

 
Thursday, February 7, 2002 7:30 AM - simon

RH 6.0 with GNOME

 
RH 6.0 with GNOME + W2K

When start Xmanager, it can find [RH IP address 0:0(Gnome)].
But it shows "XDMCP connection failed. try again?". The WINDOWS nerver comes on.
Friday, February 8, 2002 11:07 AM - Support

Re: RH 6.0 with GNOME

 
1. Please give us the result of the following command on Linux prompt:

# ps -aux | grep dm

2. And also we need the following files:

/etc/inittab
/etc/X11/gdm/gdm.conf

3. Your network configuration between the PC and Linux. (LAN or ADSL ..., firewall, gateway ...)

Looking forward to your reply.

Technical Support
Saturday, February 9, 2002 11:16 PM - Simon

Re: Re: RH 6.0 with GNOME

 
<1>
[root@linux]# ps -aux | grep dm
root 473 0.0 1.1 1888 708 ? S Feb08 0:00 sendmail: accepti
root 580 0.0 1.7 2388 1080 ? S Feb08 0:00 /etc/X11/prefdm -
root 587 0.0 0.7 2392 492 ? S Feb08 0:00 /etc/X11/prefdm -
gdm 591 0.0 4.3 5192 2764 ? S Feb08 0:00 /usr/bin/gdmgreet
root 1253 0.0 0.6 1160 428 pts/0 S 09:24 0:00 grep dm

<2>
[root@linux /etc]# more inittab
#
# inittab This file describes how the INIT process should set up
# the system in a certain run-level.
#
# Author: Miquel van Smoorenburg,
# Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

# Things to run in every runlevel.
ud::once:/sbin/update

# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes
# of power left. Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly.
pf::powerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345:powerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"


# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5
# xdm is now a separate service
x:5:respawn:/etc/X11/prefdm -nodaemon

<3>
[root@linux gdm]# more gdm.conf
[appearance]
Browser=0
Completion=0
Logo=0
LogoImage=/usr/share/pixmaps/gnome-logo-large.png
NoFaceImage=/usr/share/pixmaps/nophoto.png
GlobalImageDir=/usr/share/faces/
Quiver=1
Iconify=0
IconFile=/usr/share/pixmaps/gdm.xpm
Gtkrc=

[system]
ShutdownMenu=1
SuspendCommand=
UserFileCutoffSize=65536
UserIconMaxWidth=128
UserIconMaxHeight=128
DefaultPath=/usr/bin:/usr/local/bin:/usr/X11R6/bin:/bin

[messages]
Welcome=Welcome to %h

[daemon]
SessionDir=/etc/X11/gdm/Sessions
PidFile=/var/run/gdm.pid
Greeter=/usr/bin/gdmgreeter
Chooser=/usr/bin/gdmchooser
User=gdm
Group=gdm
DisplayInitDir=/etc/X11/gdm/Init
KillInitClients=1
PreSessionScriptDir=/etc/X11/gdm/PreSession
PostSessionScriptDir=/etc/X11/gdm/PostSession
AuthDir=/var/gdm
LogDir=/var/gdm

[servers]
0=/usr/bin/X11/X

[xdmcp]
Enable=1
MaxLoadAvg=10
MaxPending=4
MaxManageWait=20
MaxSessions=4
Port=177

[chooser]
ImageDir=/usr/share/hosts
DefaultImage=/usr/share/pixmaps/nohost.png

[debug]
Enable=0

<4> Network Structure
Peer-to-peer LAN

Thanks.

Simon
Friday, February 15, 2002 11:22 PM - Simon

Please answer me. I already did as what you asked. Thanks.

 
Please answer me.

I already did as what you asked.

Thanks.
Sunday, February 17, 2002 12:30 AM - Support

Re: Re: Re: RH 6.0 with GNOME

 
Sorry for the late response.

Your Linux is running a gdm and it's configuration looks good.
But the gdm on RedHat 6.0 has a bug in processing X terminals.

You can do one of the following two options:

1. Running xdm or kdm instead of gdm.
2. Upgrading gdm package.
We are not sure that this is possible.
Because RedHat 6.0 is a little older version
and the latest gdm couldn't be installed.


Technical Support