Xmanager Forum

RH Linux 7.2 Enterprise connection

Last post: Tuesday, January 29, 2002 4:56 PM by Support, 1 reply

Tuesday, January 29, 2002 7:59 AM - b¿

RH Linux 7.2 Enterprise connection

Hi I got these error messages when I tried to log into a redhat system, I know they got SSH installed and running. I tried all of the method of connection, no lucks, not even with SSh connection. Could someone please give me hints as to what to do?

Connected to *********:22.

Exchanging SSH version...Done.
Server: SSH-1.99-OpenSSH_2.9p2.
Client: SSH-1.5-Xssh_1.0.
SSH1 is enabled.

Authenticating remote SSH server...
Waiting for server host key...Received.
Fingerprint: 1024 e1:8f:a5:11:fc:69:13:14:fb:36:a9:b0:2d:17:3a:8b.
Verifying host key...Verified.

Negotiating cipher (encryption method)...Done.
Selected cipher: 3DES.

Trying to login as *****.
Trying password authentication...Done.

Requesting X11 forwarding...

Remote Debug Message:
No xauth program; cannot forward with spoofing.

Tuesday, January 29, 2002 4:56 PM - Support

Re: RH Linux 7.2 Enterprise connection

The xauth error could be solved by reconfiguring and recompiling openssh. The xauth command is installed with X Window package and its location should exist in your command path before installing openssh.

Please refer to the following faq messages from other site.:


< The configure process cannot find xauth! >
Check your path. Make sure you can find xauth with the "whereis xauth" or "which xauth" command. If not, add the path to xauth the way your shell likes you to do this, then run configure again.

< X authorization always fails. >
This can happen if the xauth program was not found at configure time. Correct the path, reconfigure and recompile.

It can also happen if ssh was configured with the --with-libwrap option and the necessary sshdfwd-X11: line in the /etc/hosts.allow file doesn't contain the host you are coming from.