Xmanager Forum

garbled text in xterm window

Last post: Saturday, January 12, 2002 7:29 PM by Ed Davis, 5 reply

 
Saturday, January 12, 2002 2:59 PM - Ed Davis

garbled text in xterm window

 
I have installed xmanager on a new PC and it works great and all is well. I installed it on a laptop and when I open an xterm, characters from some words on the screen get repeated and I also get random graphics on the screen. I am running on a Sony viao pcg-748, pentium processor with MMX, win98 SE, NeoMagic MagicGraph 128xd video chip with 2MB built in eDram. The random graphics disapear when I switch to 256 colors but the repeated characters persist. Do I just need more than 2MB video memory? I run 1024x768 resolution for both. Switching to 800x640 does not help. I can connect to redhat 7.2 and all of the log-in graphics stuff looks great. some little apps work well. No problems until I bring up an xterm or dtterm. Same issues and scenario if I connect to AIX common desktop. Any thoughts?
Saturday, January 12, 2002 4:05 PM - Support

Re: garbled text in xterm window

 
Please turn the "Maximize Performance" option off in the Xconfig utility. Some grahic cards don't support the fastest text operation and the option can solve it.

- Technical Support
Saturday, January 12, 2002 6:30 PM - Ed Davis

Re: Re: garbled text in xterm window

 
I tried that and there was no change. Any other ideas?
Saturday, January 12, 2002 6:34 PM - Support

Please upload a screenshot of the problem window

 
It might be a font problem. A screen capture would be a great help for the solution.
Saturday, January 12, 2002 7:12 PM

Re: Please upload a screenshot of the problem window

 
I have a screen shot but here is some more info. If I bump the color from true to 256, the graphics problems disapear but there is still a character repeating issue. Further, there seems to be a balance between having the maximize performance check box checked or not, and adjusting the hardware acceleration slide-bar in the performance tab of the display-properties advanced tab in win98. If I bump the slide bar down two notches and uncheck maximize performance it works. Should this be the solution or does this give you another idea. I really like this product but this solution seems a little hokie... I'll send a screen shot in another reply. (have to switch computers)
Saturday, January 12, 2002 7:29 PM - Ed Davis

Re: Re: Please upload a screenshot of the problem window

 
Actually, I only have to bump the hardware accelleration down two notches and I can leave the maximize performance box checked. I can't uncheck it and go up a hardware performance notch. Also just noticed that if I put a window on top of the garbled window and then take it back off, the garbling is gone and the text in the window is as it should be. I can put any kind of windows window on top of the garbled window and it will be cleaned up when the top window is moved away.



Attachment screenshot.doc ()