Xmanager Forum

Cannot access my X-window.

Last post: Thursday, November 15, 2001 10:30 PM by Support, 5 reply

 
Tuesday, November 13, 2001 5:11 PM - Anders

Cannot access my X-window.

 
Hi!

I'm trying to access a HP-UX 10.20 server. I looked in /etc/inetd.conf on the server and everything except telnet is shut down so I have to use telnet as protocol.

Since we're using DHCP, my execution command is "/usr/bin/X11/xterm -ls -display $DISPLAY"

I can see in the message window that the display variable is translated to my IP but after the command a lot of
strange characters are displayed:

----------------------------------------------------
/usr/bin/X11/xterm -ls -display 131.115.7.249:0.0
[3g[24;9HH[24;17HH[24;25HH[24;33HH[24;41HH[24;49HH[24;57HH[24;65HH[24;73HH[3g H H H H H H H H H[4l[?1h=-ksh has loaded 37 settings from /opt/XXX/env.env
-ksh PID: 7185 Started: 20011113 08:59:44
7[r[999;999H[6nresize: unknown character, exiting.
host TEST /opt/XXX/xxx $
----------------------------------------------------

If you look at the last line, it looks like I've managed to log on to the server but when I try to access my X window it's stuck as an icon down in the windows start menu thingy and no matter what I try to do with it, I cannot access the window...

... and, yeah, I'm using NT 4.0 and I've got no problems with other X programs or with windoze telnet program...

Any ideas?

/Anders
Tuesday, November 13, 2001 9:58 PM - Support

Re: Cannot access my X-window.

 
The Xstart might have a problem in parsing the shell prompt.
Please let us know the locale(language) of HP machine.
It would be very helpful for solving the problem.

Looking forward to your reply.

- Technical Support
Tuesday, November 13, 2001 10:13 PM - Anders

Re: Re: Cannot access my X-window.

 
Ok and thanks for the quick reply.

This is what I got, hope it's what you were looking for:

host TEST /opt/XXX/xxx $ locale
LANG=swedish.iso88591
LC_CTYPE="swedish.iso88591"
LC_COLLATE="swedish.iso88591"
LC_MONETARY="swedish.iso88591"
LC_NUMERIC="swedish.iso88591"
LC_TIME="swedish.iso88591"
LC_MESSAGES="swedish.iso88591"
LC_ALL=
host TEST /opt/XXX/xxx $ env | egrep -i 'lang|locale'
LANG=swedish.iso88591

All the best!
/Anders
Wednesday, November 14, 2001 9:55 PM - Support

Re: Cannot access my X-window.

 
Please remove "-ls" option in the command line. The "-ls" option processes ".profile" or ".login" script and those files might have some problems.

The command line in Xstart should be:

/usr/bin/X11/xterm -display $DISPLAY

We would appreciate your feedback.

- Technical Support
Thursday, November 15, 2001 12:03 AM - Anders

Re: Re: Cannot access my X-window.

 
Mmmm... didn't work...
I tried to remove it but the same error occured.

Just for fun I looked at the history files on the server. In the files I create when I try to use Xmanager/telnet I have:

^A^A

and a "[Incomplete last line]" message in vi....

If I look in another file (the person used reflection x/telnet to do the same thing I'm trying to do):

^A^A(/usr/bin/X11/xterm -sb -ls -display 123.123.123.123:0 -name "xterm (host.domain via TELNET)" &)

... and no incomplete last line message...

Could it be that Xmanager sends the command before the telnet session has completed the login and that the command is send to early? Or is it somehow buffered and processed when you are logged in??? Just a thought...

Is it somehow possible to config Xmanager to wait for some special characters (like somekind of expect/send script....) before you send your command. I think that would be a great feature....

The reason I checked this at all was that if I used the NT telnet and logged on to the server, started Xmanager, and wrote "xterm -ls -display MY_IP_ADDRESS:0 &" (in the telnet session) I got a xterm in windows.


Thursday, November 15, 2001 10:30 PM - Support

Xstart has been changed.

 
Xstart has been changed and you can download the updated Xmanager at:

/download/download.html

We would appreciate your feedback.

- Technical Support