Xmanager Forum

Unable to run visual-studio-code

Last post: Tuesday, July 19, 2016 7:32 AM by Support, 1 reply

 
Friday, July 15, 2016 3:43 AM - petrsnd

Unable to run visual-studio-code

 
I'm getting some libGL errors when trying to run an application from a terminal started through XManager. The application fails to load. I don't know how to get more debug that the following out of visual-studio-code, but it appears that it requires some features that XManager does not offer.

$ LIBGL_DEBUG=verbose .local/share/umake/bin/visual-studio-code
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
libGL: Can't open configuration file /home/dpeterso/.drirc: No such file or directory.
libGL: Can't open configuration file /home/dpeterso/.drirc: No such file or directory.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell

XManager 5 (Build 0786)
Client is Ubuntu 16.04 running in a VM in Hyper-V

I can successfully launch the application when I log in through the desktop as present by Hyper-V Console.

$ LIBGL_DEBUG=verbose .local/share/umake/bin/visual-studio-code
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "gail"
Gtk-Message: Failed to load module "atk-bridge"
libGL: screen 0 does not appear to by DRI2 capable
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
libGL: Can't open configuration file /home/dpeterso/.drirc: No such file or directory.
libGL: Can't open configuration file /home/dpeterso/.drirc: No such file or directory.
bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell

However, despite the errors, the application opens. The different error messages that I'm only getting from the XManager XServer appear to be:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

Is there some configuration that I need to change?

glxinfo return very different results for XManager vs. the console.

XManager:

$ glxinfo | grep "version string"
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
server glx version string: 1.2
client glx version string: 1.4
OpenGL version string: 1.1.0

console:
server glx version string: 1.4
client glx version string: 1.4
OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.2.0
OpenGL core profile shading language version string: 3.30
OpenGL version string: 3.0 Mesa 11.2.0
OpenGL shading language version string: 1.30
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.2.0
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00

Program Ver. : Xmanager 5
Connect Method : Xstart connection
Tuesday, July 19, 2016 7:32 AM - Support

Re: Unable to run visual-studio-code

 
We've done some testing and the OpenGL version of the software seems higher than that of Xmanager which may be causing the issues. We're currently investigating and will get back to you once we have more information.

Technical Support

Like us on Facebook
Follow us on Twitter
Visit our blog Blog